summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Fink2021-10-22 10:52:55 +0300
committerChristoph Fink2021-10-22 10:52:55 +0300
commit3ce6285c2a3b6462c606f4668157520a13202449 (patch)
treeb1fc7e8d6916097e8a061fc5874d983625a277a0
downloadaur-3ce6285c2a3b6462c606f4668157520a13202449.tar.gz
r-s2
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6f6440706ced
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = r-s2
+ pkgdesc = Spherical Geometry Operators Using the S2 Geometry Library
+ pkgver = 1.0.7
+ pkgrel = 1
+ url = https://cran.r-project.org/package=s2
+ arch = i686
+ arch = x86_64
+ license = Apache License (== 2.0)
+ depends = r
+ depends = r-rcpp
+ depends = r-wk
+ optdepends = r-testthat
+ optdepends = r-vctrs
+ source = https://cran.r-project.org/src/contrib/s2_1.0.7.tar.gz
+ md5sums = 95a4eb0fdd54ff6e75f00285a31b88ea
+
+pkgname = r-s2
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e8d470ea99e2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: peippo <christoph+aur@christophfink.com>
+
+_cranname=s2
+_cranver=1.0.7
+pkgname=r-${_cranname,,}
+pkgdesc="Spherical Geometry Operators Using the S2 Geometry Library"
+url="https://cran.r-project.org/package=s2"
+license=("Apache License (== 2.0)")
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+
+arch=("i686" "x86_64")
+depends=("r" "r-rcpp" "r-wk")
+optdepends=("r-testthat" "r-vctrs")
+makedepends=()
+
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+md5sums=("95a4eb0fdd54ff6e75f00285a31b88ea")
+
+build() {
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+
+ if [[ -f "${_cranname}/LICENSE" ]]; then
+ install -Dm0644 "${_cranname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ fi
+}