summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Fink2023-03-26 19:02:46 +0300
committerChristoph Fink2023-03-26 19:02:46 +0300
commit53cf066a742c58e622ef46bd6e4bc447b7c433f7 (patch)
treebe7acb24be10428712d5dca8f932d4eba81b605d
parent1c23057dfd6cb1c7edc84db9241089825c43afd8 (diff)
downloadaur-53cf066a742c58e622ef46bd6e4bc447b7c433f7.tar.gz
upgpkg: r-s2 1.1.2-3
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD35
2 files changed, 25 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba63903050bd..f041b1b675bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,15 @@
pkgbase = r-s2
pkgdesc = Spherical Geometry Operators Using the S2 Geometry Library
pkgver = 1.1.2
- pkgrel = 2
+ pkgrel = 3
url = https://cran.r-project.org/package=s2
arch = i686
arch = x86_64
license = Apache
- checkdepends = r-testthat>=3.0.0
- checkdepends = r-vctrs
depends = openssl>=1.0.1
depends = r>=3.0.0
depends = r-rcpp
depends = r-wk>=0.6.0
- optdepends = r-testthat>=3.0.0
optdepends = r-vctrs
source = https://cran.r-project.org/src/contrib/s2_1.1.2.tar.gz
b2sums = 2590bb6f1e2817393e1ee5c21e58cb3891a8b782333a1548f584f0e426ce392c7a34890332a32dbb3f3ce3dddd4f20d158dac8bc4b100e35d6a9f0fc26af81d1
diff --git a/PKGBUILD b/PKGBUILD
index ecdf3329b521..4d31c5dd9c79 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgdesc="Spherical Geometry Operators Using the S2 Geometry Library"
url="https://cran.r-project.org/package=s2"
license=(Apache)
pkgver=${_cranver//[:-]/.}
-pkgrel=2
+pkgrel=3
arch=("i686" "x86_64")
depends=(
@@ -17,14 +17,28 @@ depends=(
"r-wk>=0.6.0"
)
optdepends=(
- "r-testthat>=3.0.0"
- "r-vctrs"
-)
-checkdepends=(
- "r-testthat>=3.0.0"
"r-vctrs"
)
+# The unittests for `r-s2` have multiple circular
+# dependency chains.
+
+# As such, the tests can not be run on first build.
+# While R packages from CRAN, generally, are well-tested
+# before they are released, in some situations, you want to
+# have thorough testing on your own end.
+
+# To run the tests, first build this package without `check()`
+# (i.e., as-is) to bootstrap `r-s2`. Then, on subsequent builds,
+# (assumining you have a local repository that is accessible from
+# the build chroot), uncomment the lines defining `checkdepends`, below,
+# as well as the `check()` function further down
+
+# checkdepends=(
+# "${optdepends[@]}"
+# "r-testthat>=3.0.0"
+# )
+
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
b2sums=("2590bb6f1e2817393e1ee5c21e58cb3891a8b782333a1548f584f0e426ce392c7a34890332a32dbb3f3ce3dddd4f20d158dac8bc4b100e35d6a9f0fc26af81d1")
@@ -33,15 +47,14 @@ build() {
R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}/build/"
}
-check() {
- cd "${srcdir}/${_cranname}/tests"
- R_LIBS="${srcdir}/build/" Rscript --vanilla testthat.R
-}
+# check() {
+# export R_LIBS="build/"
+# R CMD check --no-manual "${_cranname}"
+# }
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
cp -a --no-preserve=ownership "${srcdir}/build/${_cranname}" "${pkgdir}/usr/lib/R/library"
-
if [[ -f "${_cranname}/LICENSE" ]]; then
install -Dm0644 "${_cranname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
fi