summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2023-12-12 22:28:48 +0200
committerPekka Ristola2023-12-12 22:28:48 +0200
commit40345c44718930def2fc0655b4cc5b9077de4912 (patch)
tree14e11b8375d2d97376e5d202a0f12e669389f34d
downloadaur-40345c44718930def2fc0655b4cc5b9077de4912.tar.gz
Version 1.6.0
-rw-r--r--.SRCINFO46
-rw-r--r--PKGBUILD73
2 files changed, 119 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..74c86198ced1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,46 @@
+pkgbase = r-sccomp
+ pkgdesc = Robust Outlier-aware Estimation of Composition and Heterogeneity for Single-cell Data
+ pkgver = 1.6.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/sccomp
+ arch = x86_64
+ license = GPL3
+ checkdepends = r-testthat
+ checkdepends = r-tidyseurat
+ makedepends = r-bh
+ makedepends = r-rcppeigen
+ makedepends = r-stanheaders
+ depends = r-dplyr
+ depends = r-forcats
+ depends = r-ggplot2
+ depends = r-ggrepel
+ depends = r-glue
+ depends = r-lifecycle
+ depends = r-magrittr
+ depends = r-patchwork
+ depends = r-purrr
+ depends = r-rcpp
+ depends = r-rcppparallel
+ depends = r-readr
+ depends = r-rlang
+ depends = r-rstan
+ depends = r-rstantools
+ depends = r-scales
+ depends = r-seuratobject
+ depends = r-singlecellexperiment
+ depends = r-stringr
+ depends = r-tibble
+ depends = r-tidyr
+ depends = r-tidyselect
+ optdepends = r-biocstyle
+ optdepends = r-knitr
+ optdepends = r-loo
+ optdepends = r-markdown
+ optdepends = r-testthat
+ optdepends = r-tidyseurat
+ optdepends = r-tidysinglecellexperiment
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/sccomp_1.6.0.tar.gz
+ md5sums = 8a24adb07d155b94645a5f684e1455f6
+ sha256sums = d1f4216eb85d47ff8a2f6403ab7a483b09cade88df5387ed5e9fca7f5c7c97a5
+
+pkgname = r-sccomp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd868b81303b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,73 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_pkgname=sccomp
+_pkgver=1.6.0
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="Robust Outlier-aware Estimation of Composition and Heterogeneity for Single-cell Data"
+arch=(x86_64)
+url="https://bioconductor.org/packages/${_pkgname}"
+license=(GPL3)
+depends=(
+ r-dplyr
+ r-forcats
+ r-ggplot2
+ r-ggrepel
+ r-glue
+ r-lifecycle
+ r-magrittr
+ r-patchwork
+ r-purrr
+ r-rcpp
+ r-rcppparallel
+ r-readr
+ r-rlang
+ r-rstan
+ r-rstantools
+ r-scales
+ r-seuratobject
+ r-singlecellexperiment
+ r-stringr
+ r-tibble
+ r-tidyr
+ r-tidyselect
+)
+makedepends=(
+ r-bh
+ r-rcppeigen
+ r-stanheaders
+)
+checkdepends=(
+ r-testthat
+ r-tidyseurat
+)
+optdepends=(
+ r-biocstyle
+ r-knitr
+ r-loo
+ r-markdown
+ r-testthat
+ r-tidyseurat
+ r-tidysinglecellexperiment
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('8a24adb07d155b94645a5f684e1455f6')
+sha256sums=('d1f4216eb85d47ff8a2f6403ab7a483b09cade88df5387ed5e9fca7f5c7c97a5')
+
+build() {
+ mkdir -p build
+ # compilation needs a lot of memory
+ MAKEFLAGS+=" -j1"
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+check() {
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" NOT_CRAN=true Rscript --vanilla testthat.R
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+}