summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 22:53:35 +0800
committerSukanka2022-06-06 22:53:35 +0800
commit527236e978cb744ea1707f9997b94b39f0bfcb13 (patch)
treef5f2e0bf6a52e2dcf2121722d288c1eb4f5d5968
downloadaur-527236e978cb744ea1707f9997b94b39f0bfcb13.tar.gz
add r-shinybs
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..69af7e921b44
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = r-shinybs
+ pkgdesc = Twitter Bootstrap Components for Shiny
+ pkgver = 0.61.1
+ pkgrel = 5
+ url = https://cran.r-project.org/package=shinyBS
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-htmltools
+ depends = r-shiny
+ source = https://cran.r-project.org/src/contrib/shinyBS_0.61.1.tar.gz
+ sha256sums = 0aed72473060531d0e782ba62092493002137df6b251af9e2294e2a40a32a140
+
+pkgname = r-shinybs
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..929927beb483
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=shinyBS
+_pkgver=0.61.1
+pkgname=r-${_pkgname,,}
+pkgver=0.61.1
+pkgrel=5
+pkgdesc='Twitter Bootstrap Components for Shiny'
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-htmltools
+ r-shiny
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('0aed72473060531d0e782ba62092493002137df6b251af9e2294e2a40a32a140')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: