summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 23:02:41 +0800
committerSukanka2022-06-06 23:02:41 +0800
commitdd9416a460fe7109a890f61d433ffa9677cdea33 (patch)
treeb459c8cf134b1807daa5c69726ad364c79f75a14
downloadaur-dd9416a460fe7109a890f61d433ffa9677cdea33.tar.gz
add r-siamcat
-rw-r--r--.SRCINFO42
-rw-r--r--PKGBUILD58
2 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9571afeb75ad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,42 @@
+pkgbase = r-siamcat
+ pkgdesc = Statistical Inference of Associations between Microbial Communities And host phenoTypes
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/SIAMCAT
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-beanplot
+ depends = r-corrplot
+ depends = r-glmnet
+ depends = r-gridbase
+ depends = r-gridextra
+ depends = r-infotheo
+ depends = r-liblinear
+ depends = r-matrixstats
+ depends = r-mlr
+ depends = r-paramhelpers
+ depends = r-phyloseq
+ depends = r-proc
+ depends = r-progress
+ depends = r-prroc
+ depends = r-rcolorbrewer
+ depends = r-scales
+ depends = r-stringr
+ depends = r-mlr3
+ depends = r-lmertest
+ depends = r-mlr3learners
+ depends = r-mlr3tuning
+ depends = r-paradox
+ depends = r-lgr
+ optdepends = r-biocstyle
+ optdepends = r-ggpubr
+ optdepends = r-knitr
+ optdepends = r-optparse
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ optdepends = r-tidyverse
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/SIAMCAT_2.0.0.tar.gz
+ sha256sums = 6e8c33a7e95e1f80741d69434c90eab9e84e6f4e28fb0a17f530d28421d36f81
+
+pkgname = r-siamcat
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6bf7d3a0e974
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=SIAMCAT
+_pkgver=2.0.0
+pkgname=r-${_pkgname,,}
+pkgver=2.0.0
+pkgrel=1
+pkgdesc='Statistical Inference of Associations between Microbial Communities And host phenoTypes'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-beanplot
+ r-corrplot
+ r-glmnet
+ r-gridbase
+ r-gridextra
+ r-infotheo
+ r-liblinear
+ r-matrixstats
+ r-mlr
+ r-paramhelpers
+ r-phyloseq
+ r-proc
+ r-progress
+ r-prroc
+ r-rcolorbrewer
+ r-scales
+ r-stringr
+ r-mlr3
+ r-lmertest
+ r-mlr3learners
+ r-mlr3tuning
+ r-paradox
+ r-lgr
+)
+optdepends=(
+ r-biocstyle
+ r-ggpubr
+ r-knitr
+ r-optparse
+ r-rmarkdown
+ r-testthat
+ r-tidyverse
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('6e8c33a7e95e1f80741d69434c90eab9e84e6f4e28fb0a17f530d28421d36f81')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: