summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 23:26:54 +0800
committerSukanka2022-06-06 23:26:54 +0800
commit877c2923f4c0e27b49ee7e740df0e5e74886e700 (patch)
tree6519bbbc7df82fbe80864347aef9c470b1f3e06e
downloadaur-877c2923f4c0e27b49ee7e740df0e5e74886e700.tar.gz
add r-smoother
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4cb317673b13
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = r-smoother
+ pkgdesc = Functions Relating to the Smoothing of Numerical Data
+ pkgver = 1.1
+ pkgrel = 4
+ url = https://cran.r-project.org/package=smoother
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-ttr
+ source = https://cran.r-project.org/src/contrib/smoother_1.1.tar.gz
+ sha256sums = 91b55b82f805cfa1deedacc0a4e844a2132aa59df593f3b05676954cf70a195b
+
+pkgname = r-smoother
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..742b8557f6d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=smoother
+_pkgver=1.1
+pkgname=r-${_pkgname,,}
+pkgver=1.1
+pkgrel=4
+pkgdesc='Functions Relating to the Smoothing of Numerical Data'
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-ttr
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('91b55b82f805cfa1deedacc0a4e844a2132aa59df593f3b05676954cf70a195b')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: