summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-07 00:29:54 +0800
committerSukanka2022-06-07 00:29:54 +0800
commitad1f79146165ac69a608aff9c0e8fa474c1aeb4c (patch)
treec0058dc05656c2ccbded118100d5ba288a13d40b
downloadaur-ad1f79146165ac69a608aff9c0e8fa474c1aeb4c.tar.gz
add r-spacepac
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fd72a88bb702
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = r-spacepac
+ pkgdesc = Identification of Mutational Clusters in 3D Protein Space via Simulation.
+ pkgver = 1.34.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/SpacePAC
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-ipac
+ optdepends = r-biocgenerics
+ optdepends = r-rgl
+ optdepends = r-runit
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/SpacePAC_1.34.0.tar.gz
+ sha256sums = a29fbed02d39ab05a4bdcfb4d6770faf60255f5f7cc04df74f12e6c54aa10b44
+
+pkgname = r-spacepac
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66a99c745b0e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=SpacePAC
+_pkgver=1.34.0
+pkgname=r-${_pkgname,,}
+pkgver=1.34.0
+pkgrel=1
+pkgdesc='Identification of Mutational Clusters in 3D Protein Space via Simulation.'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-ipac
+)
+optdepends=(
+ r-biocgenerics
+ r-rgl
+ r-runit
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('a29fbed02d39ab05a4bdcfb4d6770faf60255f5f7cc04df74f12e6c54aa10b44')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: