summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTaekyung Kim2019-07-12 06:57:11 +0900
committerTaekyung Kim2019-07-12 06:57:11 +0900
commit66b638d502fbf394afca66f11ca28950b4de6a9c (patch)
treeb53a8ee38e6d8fa06470ea373dcacf4ca0d97353
parent1ccb1a53f9319beaa58e2560cfd37e20fb5bf567 (diff)
downloadaur-66b638d502fbf394afca66f11ca28950b4de6a9c.tar.gz
Adoption cleanup
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed81b7e1d640..3a84e11858a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,8 +4,9 @@ pkgbase = r-sparsem
pkgrel = 1
url = https://cran.r-project.org/package=SparseM
arch = x86_64
- license = GPL
- depends = r
+ license = GPL2
+ license = GPL3
+ depends = r>=2.15
source = https://cran.r-project.org/src/contrib/SparseM_1.77.tar.gz
md5sums = bb03293245d3d66316dbbb9d0997d4d2
diff --git a/PKGBUILD b/PKGBUILD
index 45bd316210f8..55bc9a49beb6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,7 @@
+# Maintainer: Taekyung Kim <Taekyung.Kim.Maths@gmail.com>
# Contributor: Ward Segers <w@rdsegers.be>
# Contributor: Alex Branham <branham@utexas.edu>
+
_cranname=SparseM
_cranver=1.77
_pkgtar=${_cranname}_${_cranver}.tar.gz
@@ -9,19 +11,16 @@ pkgrel=1
pkgdesc="Sparse Linear Algebra"
arch=('x86_64')
url="https://cran.r-project.org/package=${_cranname}"
-license=('GPL')
-depends=('r' )
-
-
-
+license=('GPL2' 'GPL3')
+depends=('r>=2.15')
source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
md5sums=('bb03293245d3d66316dbbb9d0997d4d2')
build(){
- R CMD INSTALL ${_pkgtar} -l $srcdir
+ R CMD INSTALL "${_pkgtar}" -l "$srcdir"
}
package() {
- install -d "$pkgdir/usr/lib/R/library"
- cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
+ install -dm0755 "$pkgdir"/usr/lib/R/library
+ cp -a --no-preserve=ownership "$_cranname" "$pkgdir"/usr/lib/R/library
}