summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-06-23 18:02:30 +0000
committerBioArchLinuxBot2023-06-23 18:02:30 +0000
commitb602a6931df54aeab871cee27453a648d0e3ce4f (patch)
tree835276fe68e0c870e65d536c5c82322f90fd4dea
parent5a20e37d9a68ba076b4529c559731f54d9149a3a (diff)
downloadaur-b602a6931df54aeab871cee27453a648d0e3ce4f.tar.gz
[lilac] updated to 1.81-10
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD39
2 files changed, 27 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 672dfa041ad7..29c5471ae7cc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = r-sparsem
pkgdesc = Sparse Linear Algebra
pkgver = 1.81
- pkgrel = 1
+ pkgrel = 10
url = https://cran.r-project.org/package=SparseM
- arch = i686
arch = x86_64
- license = GPL2
- license = GPL3
+ license = GPL
makedepends = gcc-fortran
- depends = r>=2.15
+ depends = r
source = https://cran.r-project.org/src/contrib/SparseM_1.81.tar.gz
+ md5sums = 482572eed65ae53bb988a2753ce09718
sha256sums = bd838f381ace680fa38508ff70b3d83cb9ffa28ac1ab568509249bca53c34b33
pkgname = r-sparsem
diff --git a/PKGBUILD b/PKGBUILD
index 043e8d6647cd..b2676361e85e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,35 @@
-# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: Guoyi Zhang <guoyizhang at malacology dot net>
+# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Taekyung Kim <Taekyung.Kim.Maths@gmail.com>
# Contributor: Ward Segers <w@rdsegers.be>
# Contributor: Alex Branham <branham@utexas.edu>
-_cranname=SparseM
-_cranver=1.81
-pkgname=r-${_cranname,,}
-pkgver=${_cranver//[:-]/.}
-pkgrel=1
+_pkgname=SparseM
+_pkgver=1.81
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=10
pkgdesc="Sparse Linear Algebra"
-arch=(i686 x86_64)
-url="https://cran.r-project.org/package=${_cranname}"
-license=(GPL2 GPL3)
-depends=('r>=2.15')
-makedepends=(gcc-fortran)
-source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+arch=(x86_64)
+url="https://cran.r-project.org/package=${_pkgname}"
+license=(GPL)
+depends=(
+ r
+)
+makedepends=(
+ gcc-fortran
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('482572eed65ae53bb988a2753ce09718')
sha256sums=('bd838f381ace680fa38508ff70b3d83cb9ffa28ac1ab568509249bca53c34b33')
build() {
- R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
-
- cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}