summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCsonka Mihaly2019-05-02 19:10:43 +0200
committerCsonka Mihaly2019-05-02 19:10:43 +0200
commit131fb14b3fb15b395f87f4b72618d7677c3e6d1f (patch)
tree65de37791e56d4963265c064f340f93dea530f59
downloadaur-131fb14b3fb15b395f87f4b72618d7677c3e6d1f.tar.gz
Initial release package 20190502
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD24
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dcd5401c7218
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = r-spelling
+ pkgdesc = Spell checking common document formats including latex, markdown, manual pages, and description files.
+ pkgver = 2.1
+ pkgrel = 1
+ url = https://cran.r-project.org/package=spelling
+ arch = x86_64
+ license = MIT
+ depends = r
+ depends = r-commonmark
+ depends = r-xml2
+ depends = r-hunspell>=3.0
+ depends = r-knitr
+ optdepends = r-pdftools
+ source = https://cran.r-project.org/src/contrib/spelling_2.1.tar.gz
+ md5sums = e7758038652a039fc3404f7ba6930a21
+
+pkgname = r-spelling
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..186fdda9fc92
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: Kibouo <csonka.mihaly@hotmail.com>
+_cranname=spelling
+_cranver=2.1
+_pkgtar=${_cranname}_${_cranver}.tar.gz
+pkgname=r-spelling
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc='Spell checking common document formats including latex, markdown, manual pages, and description files.'
+arch=('x86_64')
+url="https://cran.r-project.org/package=${_cranname}"
+license=('MIT')
+depends=('r' 'r-commonmark' 'r-xml2' 'r-hunspell>=3.0' 'r-knitr')
+optdepends=('r-pdftools')
+source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
+md5sums=('e7758038652a039fc3404f7ba6930a21')
+
+build(){
+ R CMD INSTALL ${_pkgtar} -l $srcdir
+}
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
+}
+