summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsukanka2022-07-21 23:07:21 +0800
committersukanka2022-07-21 23:07:21 +0800
commit0d2b934d9923ec886c7180e7199c5497424a8b20 (patch)
treeb46be09a5af4e336967a092bfa9b695f3041fd20
parentf63e008779f4787bc3fc5408851fce6bb9b47b1e (diff)
downloadaur-0d2b934d9923ec886c7180e7199c5497424a8b20.tar.gz
takeover package
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD37
2 files changed, 23 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60477fb5d1d2..3efe31ab86ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = r-squarem
pkgdesc = Squared Extrapolation Methods for Accelerating EM-Like Monotone Algorithms
pkgver = 2021.1
- pkgrel = 1
+ pkgrel = 4
url = https://cran.r-project.org/package=SQUAREM
arch = any
- license = GPL2
- license = GPL3
- depends = r>=3.0
+ license = GPL
+ depends = r
optdepends = r-setrng
source = https://cran.r-project.org/src/contrib/SQUAREM_2021.1.tar.gz
sha256sums = 66e5e18ca29903e4950750bbd810f0f9df85811ee4195ce0a86d939ba8183a58
diff --git a/PKGBUILD b/PKGBUILD
index a839e08f8d04..c405d5de95f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,29 @@
-# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
-# Contributor: Alex Branham <branham@utexas.edu>
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
-_cranname=SQUAREM
-_cranver=2021.1
-pkgname=r-${_cranname,,}
-pkgver=${_cranver//[:-]/.}
-pkgrel=1
-pkgdesc="Squared Extrapolation Methods for Accelerating EM-Like Monotone Algorithms"
-arch=(any)
-url="https://cran.r-project.org/package=${_cranname}"
-license=(GPL2 GPL3)
-depends=('r>=3.0')
-optdepends=(r-setrng)
-source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+_pkgname=SQUAREM
+_pkgver=2021.1
+pkgname=r-${_pkgname,,}
+pkgver=2021.1
+pkgrel=4
+pkgdesc='Squared Extrapolation Methods for Accelerating EM-Like Monotone Algorithms'
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+)
+optdepends=(
+ r-setrng
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
sha256sums=('66e5e18ca29903e4950750bbd810f0f9df85811ee4195ce0a86d939ba8183a58')
build() {
- R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
}
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
-
- cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
}
+# vim:set ts=2 sw=2 et: