summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-07 00:45:34 +0800
committerSukanka2022-06-07 00:45:34 +0800
commitb55725b48169b8799c38c5f08ea7ec1cc40d2541 (patch)
treeada75f1a4640e993f83ce9426f85bff6742bc97c
downloadaur-b55725b48169b8799c38c5f08ea7ec1cc40d2541.tar.gz
add r-starank
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1cbb58ae90ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = r-starank
+ pkgdesc = Stability Ranking
+ pkgver = 1.38.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/staRank
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-cellhts2
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/staRank_1.38.0.tar.gz
+ sha256sums = b92a4e42a14d8ebebae3ba113a5682d0f35a6ec5572d6fb1b53ab12756787e49
+
+pkgname = r-starank
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a0bdee4c7c28
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=staRank
+_pkgver=1.38.0
+pkgname=r-${_pkgname,,}
+pkgver=1.38.0
+pkgrel=1
+pkgdesc='Stability Ranking'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-cellhts2
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('b92a4e42a14d8ebebae3ba113a5682d0f35a6ec5572d6fb1b53ab12756787e49')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: