summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-07 00:51:56 +0800
committerSukanka2022-06-07 00:51:56 +0800
commit4a4cf3a9f666dd10a8a6e64ee88169e63bf2e5ad (patch)
treefbdec0c08817801ae503024dcc607b26d19d85a0
parent199b84b42b2cd1b21346e85efbe26518cb477e04 (diff)
downloadaur-4a4cf3a9f666dd10a8a6e64ee88169e63bf2e5ad.tar.gz
add r-stringdist
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD45
2 files changed, 31 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9dfc0a07c4a2..4d28904f293e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = r-stringdist
- pkgdesc = Approximate String Matching and String Distance Functions
- pkgver = 0.9.5.1
- pkgrel = 1
+ pkgdesc = Approximate String Matching, Fuzzy Text Search, and String Distance Functions
+ pkgver = 0.9.8
+ pkgrel = 4
url = https://cran.r-project.org/package=stringdist
arch = x86_64
- license = GPL3
+ license = GPL
depends = r
- optdepends = r-testthat
- source = https://cran.r-project.org/src/contrib/stringdist_0.9.5.1.tar.gz
- md5sums = a1cf825039e43e36a368e00986396559
+ optdepends = r-tinytest
+ source = https://cran.r-project.org/src/contrib/stringdist_0.9.8.tar.gz
+ sha256sums = efccd6ccc5c74c578be95b7dae1099c52b0d7805452ab14ee91ca34adb8261bb
pkgname = r-stringdist
-
diff --git a/PKGBUILD b/PKGBUILD
index 923fa8d7414a..e36efcfae074 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,29 @@
-# Maintainer: Alex Branham <branham@utexas.edu>
-_cranname=stringdist
-_cranver=0.9.5.1
-_pkgtar=${_cranname}_${_cranver}.tar.gz
-pkgname=r-stringdist
-pkgver=${_cranver//[:-]/.}
-pkgrel=1
-pkgdesc="Approximate String Matching and String Distance Functions"
-arch=('x86_64')
-url="https://cran.r-project.org/package=${_cranname}"
-license=('GPL3')
-depends=('r' )
-
-optdepends=('r-testthat')
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
-source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
-md5sums=('a1cf825039e43e36a368e00986396559')
+_pkgname=stringdist
+_pkgver=0.9.8
+pkgname=r-${_pkgname,,}
+pkgver=0.9.8
+pkgrel=4
+pkgdesc='Approximate String Matching, Fuzzy Text Search, and String Distance Functions'
+arch=('x86_64')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+)
+optdepends=(
+ r-tinytest
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('efccd6ccc5c74c578be95b7dae1099c52b0d7805452ab14ee91ca34adb8261bb')
-build(){
- R CMD INSTALL ${_pkgtar} -l $srcdir
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
}
+
package() {
- install -d "$pkgdir/usr/lib/R/library"
- cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
}
-
+# vim:set ts=2 sw=2 et: