summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-02-07 18:01:33 +0000
committerBioArchLinuxBot2024-02-07 18:01:33 +0000
commit3abb6c38cf0d7bac33f583bbe769c1c653a00271 (patch)
tree31e2e72af5e419aa94479406d3dd2175f15b26f1
parent1f3355540a7d454d6ef203782889a4d68209c799 (diff)
downloadaur-3abb6c38cf0d7bac33f583bbe769c1c653a00271.tar.gz
[lilac] updated to 0.16.0-2
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD40
-rw-r--r--system-libs.patch24
3 files changed, 58 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef675421c432..b06daf004390 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = r-stringfish
pkgdesc = Alt String Implementation
pkgver = 0.16.0
- pkgrel = 1
+ pkgrel = 2
url = https://cran.r-project.org/package=stringfish
arch = x86_64
- license = GPL
- depends = r
+ license = GPL-3.0-only
+ depends = pcre2
depends = r-rcpp
depends = r-rcppparallel
+ depends = xxhash
optdepends = r-dplyr
optdepends = r-knitr
optdepends = r-qs
@@ -16,6 +17,10 @@ pkgbase = r-stringfish
optdepends = r-stringr
optdepends = r-usethis
source = https://cran.r-project.org/src/contrib/stringfish_0.16.0.tar.gz
- sha256sums = 3608bc83900246297b38df46954bd9aa3b6f463a56eefbe80cfc713eab797993
+ source = system-libs.patch
+ md5sums = 5ca337ca8e7eeed112eb342165a93684
+ md5sums = 685b52efc1bfcd2574e559f9df64560e
+ b2sums = b754f12ae5887ae25fade0c049653f15c61c63ce7b8cdd21323a44a95d59a16baca33cb27ad0b9df9e7d4de15f26b52647621ef79b42ef4b172cb2fea2641621
+ b2sums = a56459ada70af48192f87952f0bf3c7badf8f9f0159a9ef1cef6d0c9bb9d1faaaa61d82c4a91b4538cd37b3cbca657ddd744ce910379500a8ed8fca7f7a4fd35
pkgname = r-stringfish
diff --git a/PKGBUILD b/PKGBUILD
index 0212cca00df7..9f4d3d5a5646 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
-# system requirements: C++11, GNU make
-# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: Guoyi Zhang <guoyizhang at malacology dot net>
_pkgname=stringfish
_pkgver=0.16.0
pkgname=r-${_pkgname,,}
-pkgver=0.16.0
-pkgrel=1
-pkgdesc='Alt String Implementation'
-arch=('x86_64')
-url="https://cran.r-project.org/package=${_pkgname}"
-license=('GPL')
+pkgver=${_pkgver//-/.}
+pkgrel=2
+pkgdesc="Alt String Implementation"
+arch=(x86_64)
+url="https://cran.r-project.org/package=$_pkgname"
+license=('GPL-3.0-only')
depends=(
- r
+ pcre2
r-rcpp
r-rcppparallel
+ xxhash
)
optdepends=(
r-dplyr
@@ -24,15 +25,24 @@ optdepends=(
r-stringr
r-usethis
)
-source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('3608bc83900246297b38df46954bd9aa3b6f463a56eefbe80cfc713eab797993')
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz"
+ "system-libs.patch")
+md5sums=('5ca337ca8e7eeed112eb342165a93684'
+ '685b52efc1bfcd2574e559f9df64560e')
+b2sums=('b754f12ae5887ae25fade0c049653f15c61c63ce7b8cdd21323a44a95d59a16baca33cb27ad0b9df9e7d4de15f26b52647621ef79b42ef4b172cb2fea2641621'
+ 'a56459ada70af48192f87952f0bf3c7badf8f9f0159a9ef1cef6d0c9bb9d1faaaa61d82c4a91b4538cd37b3cbca657ddd744ce910379500a8ed8fca7f7a4fd35')
+
+prepare() {
+ # use system xxhash
+ patch -Np1 -i system-libs.patch
+}
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et:
diff --git a/system-libs.patch b/system-libs.patch
new file mode 100644
index 000000000000..355db6bdda80
--- /dev/null
+++ b/system-libs.patch
@@ -0,0 +1,24 @@
+diff --git a/stringfish/src/Makevars.in b/stringfish/src/Makevars.in
+index 821aaea..891d022 100644
+--- a/stringfish/src/Makevars.in
++++ b/stringfish/src/Makevars.in
+@@ -1,5 +1,5 @@
+ PKG_CPPFLAGS=-DRCPP_USE_UNWIND_PROTECT -DRCPP_NO_RTTI -DPCRE2_CODE_UNIT_WIDTH=8 -DHAVE_CONFIG_H @PCRE2_BUNDLED@ -I. @INCLUDE_PATHS@
+-PKG_LIBS=-lpthread -L. -lSFPCRE2 @ADD_LIBS@ $(shell ${R_HOME}/bin/Rscript -e "RcppParallel::RcppParallelLibs()")
++PKG_LIBS := -lxxhash -lpthread -L. -lSFPCRE2 @ADD_LIBS@ $(shell ${R_HOME}/bin/Rscript -e "RcppParallel::RcppParallelLibs()")
+
+ LIBPCRE2 = PCRE2/pcre2_chartables.o \
+ PCRE2/pcre2_auto_possess.o \
+diff --git a/stringfish/src/sf_functions.cpp b/stringfish/src/sf_functions.cpp
+index 17f545b..a43a87e 100644
+--- a/stringfish/src/sf_functions.cpp
++++ b/stringfish/src/sf_functions.cpp
+@@ -99,7 +99,7 @@ List get_pcre2_info() {
+ #include <unordered_map>
+ #include <fstream>
+
+-#include "xxhash/xxhash.c"
++#include <xxhash.h>
+
+ ////////////////////////////////////////////////////////////////////////////////
+ // iconv helper class