summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2019-02-09 10:49:29 +0000
committerGrey Christoforo2019-02-09 10:49:29 +0000
commit0a9a6a3322914f41d0cb6b97c45505348fb336e9 (patch)
treed63ceeff9030830398aecfcf9ec76808fc42b52c
parent30cb1f06f88b4a6150f776379cc290a90d4aec3d (diff)
downloadaur-0a9a6a3322914f41d0cb6b97c45505348fb336e9.tar.gz
bump version
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 19 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6122501f0755..d9f9bc6674ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,11 +2,11 @@ pkgbase = r-stringi
pkgdesc = Character String Processing Facilities
pkgver = 1.2.4
pkgrel = 1
- url = https://cran.r-project.org/package=stringi
+ url = http://cran.r-project.org/web/packages/stringi/index.html
arch = x86_64
- license = custom
+ license = GPL3
depends = r
- source = https://cran.r-project.org/src/contrib/stringi_1.2.4.tar.gz
+ source = http://cran.r-project.org/src/contrib/stringi_1.2.4.tar.gz
md5sums = aeb53ac931b033bdde5792cf8fd2e3cc
pkgname = r-stringi
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6ae0b18a1f6c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index abf107c28163..28e59861ea7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,19 @@
-# Maintainer: Alex Branham <branham@utexas.edu>
-_cranver=1.2.4
+# Contributor: Grey Christoforo <first name at last name dot net>
pkgname=r-stringi
-pkgver=${_cranver//[:-]/.}
+_cran_name=stringi
+pkgver=1.2.4
pkgrel=1
-pkgdesc='Character String Processing Facilities'
+pkgdesc="Character String Processing Facilities"
arch=('x86_64')
-url='https://cran.r-project.org/package=stringi'
-license=('custom')
-depends=('r' )
-source=("https://cran.r-project.org/src/contrib/stringi_"$_cranver".tar.gz")
+url="http://cran.r-project.org/web/packages/${_cran_name}/index.html"
+license=('GPL3')
+depends=('r')
+source=("http://cran.r-project.org/src/contrib/${_cran_name}_${pkgver}.tar.gz")
md5sums=('aeb53ac931b033bdde5792cf8fd2e3cc')
-build(){
- R CMD INSTALL stringi_"$_cranver".tar.gz -l "$srcdir"
-}
package() {
- install -dm0755 "$pkgdir"/usr/lib/R/library
- cp -a --no-preserve=ownership stringi "$pkgdir"/usr/lib/R/library
-}
+ mkdir -p $pkgdir/usr/lib/R/library
+ cd $srcdir
+ R CMD INSTALL -l $pkgdir/usr/lib/R/library ./${_cran_name}
+}