summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiang Gao2016-08-11 12:25:46 -0400
committerXiang Gao2016-08-11 12:25:46 -0400
commit86137d60ccc74a75bec03fd8cbb0e70fd37fe7e5 (patch)
treeac57fdf985209d2fae957fef1dc11a3edfebc2e1
downloadaur-86137d60ccc74a75bec03fd8cbb0e70fd37fe7e5.tar.gz
init version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5a9634257065
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = r-stringi
+ pkgdesc = character string processing facilities
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = http://www.gagolewski.com/software/stringi/ http://site.icu-project.org/ http://www.unicode.org/
+ arch = any
+ license = custom
+ makedepends = curl
+ makedepends = grep
+ makedepends = python-html2text
+ depends = r>=2.13.1
+
+pkgname = r-stringi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35313a873115
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: generated by script at https://github.com/zasdfgbnm/aurcran
+
+_pkgname=stringi
+_pkgnamelower=stringi
+_repo='http://cran.stat.ucla.edu/'
+_cran="https://cran.r-project.org/web/packages/$_pkgname/index.html"
+pkgname=r-$_pkgnamelower
+pkgver=1.1.1
+pkgrel=1
+pkgdesc='character string processing facilities'
+arch=(any)
+url="http://www.gagolewski.com/software/stringi/
+http://site.icu-project.org/ http://www.unicode.org/"
+license=('custom')
+depends=('r>=2.13.1')
+makedepends=('curl' 'grep' 'python-html2text')
+
+pkgver() {
+ curl "$_cran" 2>/dev/null|html2text|grep -oP '(?<=Version:).*'|grep -o '[0-9\.]*'
+}
+
+build() {
+ Rscript -e "install.packages(\"$_pkgname\", lib=\"$srcdir\", repos=\"$_repo\")"
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -r "$srcdir/$_pkgname" "$pkgdir/usr/lib/R/library"
+} \ No newline at end of file