summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Branham2018-05-31 11:38:43 -0500
committerAlex Branham2018-05-31 11:38:43 -0500
commitec0134a194335c1f7b07838c7c160e3ee84decca (patch)
treea1a3d477fe6affc90b9cb90da5ade71e357793f5
parentb8da06aad5e48e5c7ce2ffdbf7a67a63d2c296f2 (diff)
downloadaur-ec0134a194335c1f7b07838c7c160e3ee84decca.tar.gz
Upkg 1.2.2
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD41
2 files changed, 26 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a9634257065..4498cffe73fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = r-stringi
- pkgdesc = character string processing facilities
- pkgver = 1.1.1
+ pkgdesc = Character String Processing Facilities
+ pkgver = 1.2.2
pkgrel = 1
- url = http://www.gagolewski.com/software/stringi/ http://site.icu-project.org/ http://www.unicode.org/
- arch = any
+ url = https://cran.r-project.org/package=stringi
+ arch = x86_64
license = custom
- makedepends = curl
- makedepends = grep
- makedepends = python-html2text
- depends = r>=2.13.1
+ depends = r
+ source = https://cran.r-project.org/src/contrib/stringi_1.2.2.tar.gz
+ md5sums = 815e5ffc073eea5e10cf56a1af12facc
pkgname = r-stringi
diff --git a/PKGBUILD b/PKGBUILD
index 6da3e13e3591..0b7889c329c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,26 @@
-# Maintainer: generated by script at https://github.com/zasdfgbnm/aurcran
-
-_pkgname=stringi
-_pkgnamelower=stringi
-_repo='http://cran.stat.ucla.edu/'
-_cran="https://cran.r-project.org/web/packages/$_pkgname/index.html"
-pkgname=r-$_pkgnamelower
-pkgver=1.1.1
+# Maintainer: Alex Branham <branham@utexas.edu>
+_cranname=stringi
+_cranver=1.2.2
+_pkgtar=${_cranname}_${_cranver}.tar.gz
+pkgname=r-stringi
+pkgver=${_cranver//[:-]/.}
pkgrel=1
-pkgdesc='character string processing facilities'
-arch=(any)
-url="http://www.gagolewski.com/software/stringi/
-http://site.icu-project.org/ http://www.unicode.org/"
+pkgdesc="Character String Processing Facilities"
+arch=('x86_64')
+url="https://cran.r-project.org/package=${_cranname}"
license=('custom')
-depends=('r>=2.13.1')
-makedepends=('curl' 'grep' 'python-html2text')
+depends=('r' )
-pkgver() {
- curl "$_cran" 2>/dev/null|html2text|grep -oP '(?<=Version:).*'|tr '-' '.'|grep -o '[0-9\.]*'
-}
-build() {
- Rscript -e "install.packages(\"$_pkgname\", lib=\"$srcdir\", repos=\"$_repo\")"
-}
+source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
+md5sums=('815e5ffc073eea5e10cf56a1af12facc')
+
+build(){
+ R CMD INSTALL ${_pkgtar} -l $srcdir
+}
package() {
install -d "$pkgdir/usr/lib/R/library"
- cp -r "$srcdir/$_pkgname" "$pkgdir/usr/lib/R/library"
-} \ No newline at end of file
+ cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
+}
+