summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-07 01:09:43 +0800
committerSukanka2022-06-07 01:09:43 +0800
commit3742f677fcce26abf2959ba6043d17f797612bcc (patch)
tree40b4229679a30513fb6a1672384b74f0a5644143
downloadaur-3742f677fcce26abf2959ba6043d17f797612bcc.tar.gz
add r-swfdr
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD36
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f82660345f6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = r-swfdr
+ pkgdesc = Estimation of the science-wise false discovery rate and the false discovery rate conditional on covariates
+ pkgver = 1.22.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/swfdr
+ arch = any
+ license = GPL
+ depends = r
+ optdepends = r-biocstyle
+ optdepends = r-dplyr
+ optdepends = r-ggplot2
+ optdepends = r-knitr
+ optdepends = r-qvalue
+ optdepends = r-reshape2
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/swfdr_1.22.0.tar.gz
+ sha256sums = de6af07af8945a1e09a03dc49e0ac8abc7b5b870573d3bf32e1158e6d0a86abe
+
+pkgname = r-swfdr
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..86b484990533
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=swfdr
+_pkgver=1.22.0
+pkgname=r-${_pkgname,,}
+pkgver=1.22.0
+pkgrel=1
+pkgdesc='Estimation of the science-wise false discovery rate and the false discovery rate conditional on covariates'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+)
+optdepends=(
+ r-biocstyle
+ r-dplyr
+ r-ggplot2
+ r-knitr
+ r-qvalue
+ r-reshape2
+ r-rmarkdown
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('de6af07af8945a1e09a03dc49e0ac8abc7b5b870573d3bf32e1158e6d0a86abe')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: