summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-07 01:10:35 +0800
committerSukanka2022-06-07 01:10:35 +0800
commit363251414c39d3a04b0d4d0535a6940bc0bf972a (patch)
tree5b00acb5f6d9d57aefb62d1290d756ece35821f1
downloadaur-363251414c39d3a04b0d4d0535a6940bc0bf972a.tar.gz
add r-switchbox
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad7ccc0dc55b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = r-switchbox
+ pkgdesc = Utilities to train and validate classifiers based on pair switching using the K-Top-Scoring-Pair (KTSP) algorithm
+ pkgver = 1.32.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/switchBox
+ arch = x86_64
+ license = GPL
+ depends = r
+ depends = r-gplots
+ depends = r-proc
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/switchBox_1.32.0.tar.gz
+ sha256sums = 45e201cb2f5b381be1aafd469626a9c4caa3b6873adecaa9e88e04d56dd4de3b
+
+pkgname = r-switchbox
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d368e1110860
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=switchBox
+_pkgver=1.32.0
+pkgname=r-${_pkgname,,}
+pkgver=1.32.0
+pkgrel=1
+pkgdesc='Utilities to train and validate classifiers based on pair switching using the K-Top-Scoring-Pair (KTSP) algorithm'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-gplots
+ r-proc
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('45e201cb2f5b381be1aafd469626a9c4caa3b6873adecaa9e88e04d56dd4de3b')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: