summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2020-02-23 22:14:04 +0300
committerViktor Drobot2020-02-23 22:14:04 +0300
commit5071bcfc76dad69a40a01333efcf10b00359af00 (patch)
treeecdf9d99f5f4fd01f58e8f8430a1d936c23e136e
downloadaur-5071bcfc76dad69a40a01333efcf10b00359af00.tar.gz
Initial release
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..16aef620aac3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = r-systemfonts
+ pkgdesc = System Native Font Finding
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://cran.r-project.org/package=systemfonts
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = gcc
+ depends = r
+ optdepends = r-testthat
+ optdepends = r-covr
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ source = https://cran.r-project.org/src/contrib/systemfonts_0.1.1.tar.gz
+ md5sums = 0f68f951fa77677882d6bb1226ed92ed
+
+pkgname = r-systemfonts
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d00591cddc51
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+
+_cranname=systemfonts
+_cranver=0.1.1
+pkgname=r-${_cranname,,}
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc="System Native Font Finding"
+arch=(i686 x86_64)
+url="https://cran.r-project.org/package=${_cranname}"
+license=(MIT)
+depends=(r)
+makedepends=(gcc)
+optdepends=(r-testthat r-covr r-knitr r-rmarkdown)
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+md5sums=('0f68f951fa77677882d6bb1226ed92ed')
+
+build() {
+ cd "${srcdir}"
+
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
+}
+
+package() {
+ cd "${srcdir}"
+
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+}