summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-07 01:17:18 +0800
committerSukanka2022-06-07 01:17:18 +0800
commit4b2a4cf2b54caf01b1b69c972cbb2c8e969b79ac (patch)
treeb5bc047e924caecb60516c2856c5a67287cc5639
downloadaur-4b2a4cf2b54caf01b1b69c972cbb2c8e969b79ac.tar.gz
add r-tanggle
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD37
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b78f5a37f3a9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = r-tanggle
+ pkgdesc = Visualization of Phylogenetic Networks
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/tanggle
+ arch = any
+ license = Artistic2.0
+ depends = r
+ depends = r-ape
+ depends = r-ggplot2
+ depends = r-ggtree
+ depends = r-phangorn
+ optdepends = r-biocstyle
+ optdepends = r-ggimage
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ optdepends = r-tinytest
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/tanggle_1.2.0.tar.gz
+ sha256sums = ec38f5534bb7913d02df0352013cae436ddfcfc67dde5f89a780f3847bc504e4
+
+pkgname = r-tanggle
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c6410725341b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=tanggle
+_pkgver=1.2.0
+pkgname=r-${_pkgname,,}
+pkgver=1.2.0
+pkgrel=1
+pkgdesc='Visualization of Phylogenetic Networks'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-ape
+ r-ggplot2
+ r-ggtree
+ r-phangorn
+)
+optdepends=(
+ r-biocstyle
+ r-ggimage
+ r-knitr
+ r-rmarkdown
+ r-tinytest
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('ec38f5534bb7913d02df0352013cae436ddfcfc67dde5f89a780f3847bc504e4')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: