summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-07 01:20:40 +0800
committerSukanka2022-06-07 01:20:40 +0800
commit29f280215fda9c968a3fefa4a912ea2c61e2c0ae (patch)
treeb669e7ea738fd174ccfca1e47afe4a34ae213c3f
downloadaur-29f280215fda9c968a3fefa4a912ea2c61e2c0ae.tar.gz
add r-tbsignatureprofiler
-rw-r--r--.SRCINFO51
-rw-r--r--PKGBUILD68
2 files changed, 119 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6904b9edeb54
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,51 @@
+pkgbase = r-tbsignatureprofiler
+ pkgdesc = Profile RNA-Seq Data Using TB Pathway Signatures
+ pkgver = 1.8.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/TBSignatureProfiler
+ arch = any
+ license = MIT
+ depends = r
+ depends = r-assign
+ depends = r-biocgenerics
+ depends = r-biocparallel
+ depends = r-complexheatmap
+ depends = r-deseq2
+ depends = r-dt
+ depends = r-edger
+ depends = r-gdata
+ depends = r-ggplot2
+ depends = r-gsva
+ depends = r-magrittr
+ depends = r-rcolorbrewer
+ depends = r-reshape2
+ depends = r-rlang
+ depends = r-rocit
+ depends = r-s4vectors
+ depends = r-singscore
+ depends = r-summarizedexperiment
+ optdepends = r-biocstyle
+ optdepends = r-caret
+ optdepends = r-circlize
+ optdepends = r-class
+ optdepends = r-covr
+ optdepends = r-dplyr
+ optdepends = r-e1071
+ optdepends = r-glmnet
+ optdepends = r-hgnchelper
+ optdepends = r-impute
+ optdepends = r-knitr
+ optdepends = r-lintr
+ optdepends = r-mass
+ optdepends = r-plyr
+ optdepends = r-proc
+ optdepends = r-randomforest
+ optdepends = r-rmarkdown
+ optdepends = r-shiny
+ optdepends = r-spelling
+ optdepends = r-sva
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/TBSignatureProfiler_1.8.0.tar.gz
+ sha256sums = 7ace22a01a0983fca1e23290132f39dff3383f4bdf588529c1d8d4fc466eecda
+
+pkgname = r-tbsignatureprofiler
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be9d1b103e0f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=TBSignatureProfiler
+_pkgver=1.8.0
+pkgname=r-${_pkgname,,}
+pkgver=1.8.0
+pkgrel=1
+pkgdesc='Profile RNA-Seq Data Using TB Pathway Signatures'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('MIT')
+depends=(
+ r
+ r-assign
+ r-biocgenerics
+ r-biocparallel
+ r-complexheatmap
+ r-deseq2
+ r-dt
+ r-edger
+ r-gdata
+ r-ggplot2
+ r-gsva
+ r-magrittr
+ r-rcolorbrewer
+ r-reshape2
+ r-rlang
+ r-rocit
+ r-s4vectors
+ r-singscore
+ r-summarizedexperiment
+)
+optdepends=(
+ r-biocstyle
+ r-caret
+ r-circlize
+ r-class
+ r-covr
+ r-dplyr
+ r-e1071
+ r-glmnet
+ r-hgnchelper
+ r-impute
+ r-knitr
+ r-lintr
+ r-mass
+ r-plyr
+ r-proc
+ r-randomforest
+ r-rmarkdown
+ r-shiny
+ r-spelling
+ r-sva
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('7ace22a01a0983fca1e23290132f39dff3383f4bdf588529c1d8d4fc466eecda')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -Dm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+# vim:set ts=2 sw=2 et: