summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-07 01:26:04 +0800
committerSukanka2022-06-07 01:26:04 +0800
commitee8254e676092bfb70256617d0564678a0c04885 (patch)
tree21133a4e3e012b37c4a691cd4ed085bb2e1a405a
downloadaur-ee8254e676092bfb70256617d0564678a0c04885.tar.gz
add r-tensorflow
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD39
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc4acb420074
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = r-tensorflow
+ pkgdesc = R Interface to 'TensorFlow'
+ pkgver = 2.9.0
+ pkgrel = 3
+ url = https://cran.r-project.org/package=tensorflow
+ arch = any
+ license = Apache
+ depends = r
+ depends = r-config
+ depends = r-processx
+ depends = r-reticulate
+ depends = r-rstudioapi
+ depends = r-tfautograph
+ depends = r-tfruns
+ depends = r-yaml
+ optdepends = r-callr
+ optdepends = r-keras
+ optdepends = r-testthat
+ source = https://cran.r-project.org/src/contrib/tensorflow_2.9.0.tar.gz
+ sha256sums = d27e017fe48a8179a192099bec31e41abe24e8bbe9fe3b95c4ce3cd27bb38689
+
+pkgname = r-tensorflow
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ffac1be3ac5a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# system requirements: TensorFlow (https://www.tensorflow.org/)
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=tensorflow
+_pkgver=2.9.0
+pkgname=r-${_pkgname,,}
+pkgver=2.9.0
+pkgrel=3
+pkgdesc="R Interface to 'TensorFlow'"
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('Apache')
+depends=(
+ r
+ r-config
+ r-processx
+ r-reticulate
+ r-rstudioapi
+ r-tfautograph
+ r-tfruns
+ r-yaml
+)
+optdepends=(
+ r-callr
+ r-keras
+ r-testthat
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('d27e017fe48a8179a192099bec31e41abe24e8bbe9fe3b95c4ce3cd27bb38689')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: