summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2022-01-18 22:53:51 +0300
committerViktor Drobot2022-01-18 22:53:51 +0300
commit9b715b124f971e633ca700404b8d1e224ff125ec (patch)
treed2d3401ff03d353d1d674fa4adbd4c84ca43bfd1
parentd5ec624506fd134ff69ff048e63097c317ea2506 (diff)
downloadaur-9b715b124f971e633ca700404b8d1e224ff125ec.tar.gz
Fix PKGBUILD
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD9
2 files changed, 3 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5e4a3684130..1651cc2f1238 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,4 +12,3 @@ pkgbase = r-testit
sha256sums = 90d47168ab6bdbd1274b600b457626ac07697ce09792c92b2043be5f5b678d80
pkgname = r-testit
-
diff --git a/PKGBUILD b/PKGBUILD
index 303b5826b1fc..0e57281995c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Kibouo <csonka.mihaly@hotmail.com>
# Contributor: Alex Branham <branham@utexas.edu>
@@ -17,14 +17,11 @@ source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz"
sha256sums=('90d47168ab6bdbd1274b600b457626ac07697ce09792c92b2043be5f5b678d80')
build() {
- cd "${srcdir}"
-
- R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
}
package() {
- cd "${srcdir}"
-
install -dm0755 "${pkgdir}/usr/lib/R/library"
+
cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
}