summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCsonka Mihaly2019-05-02 20:07:10 +0200
committerCsonka Mihaly2019-05-02 20:07:10 +0200
commita2f398b61da7e94a530fb8260e5aac6c4b36b4ab (patch)
tree82ba7150e5230034ba0d79dcb184f4012ba0e730
downloadaur-a2f398b61da7e94a530fb8260e5aac6c4b36b4ab.tar.gz
Bump version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1d642de4f762
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = r-testit
+ pkgdesc = Provides two convenience functions assert() and test_pkg() to facilitate testing R packages.
+ pkgver = 0.9
+ pkgrel = 1
+ url = https://cran.r-project.org/package=testit
+ arch = x86_64
+ license = GPL-2
+ license = GPL-3
+ depends = r
+ optdepends = r-rstudioapi
+ source = https://cran.r-project.org/src/contrib/Archive/testit/testit_0.9.tar.gz
+ md5sums = e19c52232a32060e86d8bef6f76b7d79
+
+pkgname = r-testit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3e3500c0321
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: Kibouo <csonka.mihaly@hotmail.com>
+# Contributor: Alex Branham <branham@utexas.edu>
+_cranname=testit
+_cranver=0.9
+_pkgtar=${_cranname}_${_cranver}.tar.gz
+pkgname=r-testit
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc='Provides two convenience functions assert() and test_pkg() to facilitate testing R packages.'
+arch=('x86_64')
+url="https://cran.r-project.org/package=${_cranname}"
+license=('GPL-2' 'GPL-3')
+depends=('r')
+optdepends=('r-rstudioapi')
+source=("https://cran.r-project.org/src/contrib/Archive/${_cranname}/${_pkgtar}")
+md5sums=('e19c52232a32060e86d8bef6f76b7d79')
+
+build(){
+ R CMD INSTALL ${_pkgtar} -l $srcdir
+}
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
+}
+