summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Branham2018-10-15 11:48:41 -0500
committerAlex Branham2018-10-15 11:48:41 -0500
commit8ca16c56a3862e4f6e7e5c609c3311e4a95c18bf (patch)
tree5c09c017e9caa6deda84636412c4674d5927ef71
parentdeefbb7108fd289afed9253cac32fab9b6b453b7 (diff)
downloadaur-8ca16c56a3862e4f6e7e5c609c3311e4a95c18bf.tar.gz
Upkg 2.0.1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD24
2 files changed, 14 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 374f5edb2d50..470ebd75ecf0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = r-testthat
pkgdesc = Unit Testing for R
- pkgver = 2.0.0
+ pkgver = 2.0.1
pkgrel = 1
url = https://cran.r-project.org/package=testthat
arch = x86_64
@@ -18,9 +18,10 @@ pkgbase = r-testthat
optdepends = r-devtools
optdepends = r-knitr
optdepends = r-rmarkdown
+ optdepends = r-usethis
optdepends = r-xml2
- source = https://cran.r-project.org/src/contrib/testthat_2.0.0.tar.gz
- md5sums = 36765e0ad2e29b825b4c6088b1a34458
+ source = https://cran.r-project.org/src/contrib/testthat_2.0.1.tar.gz
+ md5sums = d35da4e4c876c444058f7d26a10600be
pkgname = r-testthat
diff --git a/PKGBUILD b/PKGBUILD
index f83925776f63..9bcb99dbbb2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,22 @@
-# Maintainer: Alex Branham <branham@utexas.edu>
-_cranname=testthat
-_cranver=2.0.0
-_pkgtar=${_cranname}_${_cranver}.tar.gz
+# Maintainer: Alex Branham <alex.branham@gmail.com>
+_cranver=2.0.1
pkgname=r-testthat
pkgver=${_cranver//[:-]/.}
pkgrel=1
-pkgdesc="Unit Testing for R"
+pkgdesc='Unit Testing for R'
arch=('x86_64')
-url="https://cran.r-project.org/package=${_cranname}"
+url='https://cran.r-project.org/package=testthat'
license=('MIT')
depends=('r' 'r-cli' 'r-crayon' 'r-digest' 'r-magrittr' 'r-praise' 'r-r6>=2.2.0' 'r-rlang' 'r-withr>=2.0.0')
-
-optdepends=('r-covr' 'r-devtools' 'r-knitr' 'r-rmarkdown' 'r-xml2')
-
-source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
-md5sums=('36765e0ad2e29b825b4c6088b1a34458')
+optdepends=('r-covr' 'r-devtools' 'r-knitr' 'r-rmarkdown' 'r-usethis' 'r-xml2')
+source=("https://cran.r-project.org/src/contrib/testthat_"$_cranver".tar.gz")
+md5sums=('d35da4e4c876c444058f7d26a10600be')
build(){
- R CMD INSTALL ${_pkgtar} -l $srcdir
+ R CMD INSTALL testthat_"$_cranver".tar.gz -l "$srcdir"
}
package() {
- install -d "$pkgdir/usr/lib/R/library"
- cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
+ install -dm0755 "$pkgdir"/usr/lib/R/library
+ cp -a --no-preserve=ownership testthat "$pkgdir"/usr/lib/R/library
}