summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-07 01:31:56 +0800
committerSukanka2022-06-07 01:31:56 +0800
commit5d786366d6eaffaa35c09acf47612ba786248213 (patch)
tree47ad59029a245d6c88a3c647650f93bb68a104b4
downloadaur-5d786366d6eaffaa35c09acf47612ba786248213.tar.gz
add r-tfisher
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d1898d6b6ab3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = r-tfisher
+ pkgdesc = Optimal Thresholding Fisher's P-Value Combination Method
+ pkgver = 0.2.0
+ pkgrel = 3
+ url = https://cran.r-project.org/package=TFisher
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-mvtnorm
+ depends = r-sn
+ source = https://cran.r-project.org/src/contrib/TFisher_0.2.0.tar.gz
+ sha256sums = bd9b7484d6fba0165841596275b446f85ba446d40e92f3b9cb37381a3827e76f
+
+pkgname = r-tfisher
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e85dbd0ae04e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=TFisher
+_pkgver=0.2.0
+pkgname=r-${_pkgname,,}
+pkgver=0.2.0
+pkgrel=3
+pkgdesc="Optimal Thresholding Fisher's P-Value Combination Method"
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-mvtnorm
+ r-sn
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('bd9b7484d6fba0165841596275b446f85ba446d40e92f3b9cb37381a3827e76f')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: