summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Frichtl2018-05-30 21:14:11 -0400
committerMatt Frichtl2018-05-30 21:14:11 -0400
commitf18eeafcc9821dfa978bf6572e09ee71c7976c08 (patch)
tree32ef24b0fc54f95c0c2157206c7c6967a9236dba
downloadaur-f18eeafcc9821dfa978bf6572e09ee71c7976c08.tar.gz
Initial commit.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD19
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fb33c3e68c0a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = r-tidyselect
+ pkgdesc = A backend for the selecting functions of the 'tidyverse'.
+ pkgver = 0.2.4
+ pkgrel = 1
+ url = http://cran.r-project.org/web/packages/tidyselect/index.html
+ arch = i686
+ arch = x86_64
+ license = GPL-3
+ depends = r>=3.1
+ depends = r-glue
+ depends = r-purrr
+ depends = r-rlang>=0.2.0
+ depends = r-rcpp>=0.12.0
+ source = http://cran.r-project.org/src/contrib/tidyselect_0.2.4.tar.gz
+ md5sums = fa3bfe6ea9f0e98a20e950788ea9573d
+
+pkgname = r-tidyselect
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60661649a5bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: frichtlm <frichtlm@gmail.com>
+_cranname=tidyselect
+_cranver=0.2.4
+pkgname=r-$_cranname
+pkgver=${_cranver}
+pkgrel=1
+pkgdesc="A backend for the selecting functions of the 'tidyverse'."
+url="http://cran.r-project.org/web/packages/${_cranname}/index.html"
+arch=('i686' 'x86_64')
+license=('GPL-3')
+depends=('r>=3.1' 'r-glue' 'r-purrr' 'r-rlang>=0.2.0' 'r-rcpp>=0.12.0')
+source=("http://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+md5sums=('fa3bfe6ea9f0e98a20e950788ea9573d')
+
+package() {
+ mkdir -p ${pkgdir}/usr/lib/R/library
+ cd ${srcdir}
+ R CMD INSTALL ${_cranname} -l ${pkgdir}/usr/lib/R/library
+}