summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2020-01-31 19:07:20 +0300
committerViktor Drobot2020-01-31 19:07:20 +0300
commit76c16ef8173fa63f0d1307bb2ff40261808d6956 (patch)
treeb91c126504ed70e2db1255f26ee20ed02bb31f93
downloadaur-76c16ef8173fa63f0d1307bb2ff40261808d6956.tar.gz
First release
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD29
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5f5b17538b5d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = r-tikzdevice
+ pkgdesc = R Graphics Output in LaTeX Format
+ pkgver = 0.12.3
+ pkgrel = 1
+ url = https://cran.r-project.org/package=tikzDevice
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ license = GPL3
+ makedepends = gcc
+ depends = r>=2.14.0
+ depends = r-filehash>=2.3
+ depends = r-png
+ depends = libpgf>=2.00
+ optdepends = r-evaluate
+ optdepends = r-formatr
+ optdepends = r-ggplot2
+ optdepends = r-knitr
+ optdepends = r-lattice
+ optdepends = r-maps
+ optdepends = r-scales
+ optdepends = r-stringr
+ optdepends = r-testthat
+ optdepends = r-withr
+ source = https://cran.r-project.org/src/contrib/tikzDevice_0.12.3.tar.gz
+ md5sums = 1772db47dad3ecbe23b2a0523ba4b4e8
+
+pkgname = r-tikzdevice
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..53b38a7b9612
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+
+_cranname=tikzDevice
+_cranver=0.12.3
+pkgname=r-${_cranname,,}
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc="R Graphics Output in LaTeX Format"
+arch=(i686 x86_64)
+url="https://cran.r-project.org/package=${_cranname}"
+license=(GPL2 GPL3)
+depends=('r>=2.14.0' 'r-filehash>=2.3' r-png 'libpgf>=2.00')
+makedepends=(gcc)
+optdepends=(r-evaluate r-formatr r-ggplot2 r-knitr r-lattice r-maps r-scales r-stringr r-testthat r-withr)
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+md5sums=('1772db47dad3ecbe23b2a0523ba4b4e8')
+
+build() {
+ cd "${srcdir}"
+
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
+}
+
+package() {
+ cd "${srcdir}"
+
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+}