summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2022-01-17 22:47:47 +0300
committerViktor Drobot2022-01-17 22:47:47 +0300
commitfd822b70bb9da09c15f2aa08dcfd602113cd03b3 (patch)
treeab2dcf8e2148a3d1043467bf2dac2f725a9156e2
parent727458f20f11e159b53482f455dab34f77ecb93b (diff)
downloadaur-fd822b70bb9da09c15f2aa08dcfd602113cd03b3.tar.gz
Fix PKGBUILD
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 5 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 57829973f7ad..c7903dc43c90 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,7 +7,6 @@ pkgbase = r-tikzdevice
arch = x86_64
license = GPL2
license = GPL3
- makedepends = gcc
depends = r>=2.14.0
depends = r-filehash>=2.3
depends = r-png
@@ -23,7 +22,6 @@ pkgbase = r-tikzdevice
optdepends = r-testthat
optdepends = r-withr
source = https://cran.r-project.org/src/contrib/tikzDevice_0.12.3.1.tar.gz
- md5sums = 1f1cfeea483220306944046dff5eafe9
+ sha256sums = 5bed80c0fca8806f0d0c0c2930e7184119b3abd7275165530d251410b9f91e10
pkgname = r-tikzdevice
-
diff --git a/PKGBUILD b/PKGBUILD
index 18501846aed9..87bd42ab63fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
_cranname=tikzDevice
_cranver=0.12.3.1
@@ -10,20 +10,16 @@ arch=(i686 x86_64)
url="https://cran.r-project.org/package=${_cranname}"
license=(GPL2 GPL3)
depends=('r>=2.14.0' 'r-filehash>=2.3' r-png 'libpgf>=2.00')
-makedepends=(gcc)
optdepends=(r-evaluate r-formatr r-ggplot2 r-knitr r-lattice r-maps r-scales r-stringr r-testthat r-withr)
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-md5sums=('1f1cfeea483220306944046dff5eafe9')
+sha256sums=('5bed80c0fca8806f0d0c0c2930e7184119b3abd7275165530d251410b9f91e10')
build() {
- cd "${srcdir}"
-
- R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
}
package() {
- cd "${srcdir}"
-
install -dm0755 "${pkgdir}/usr/lib/R/library"
+
cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
}