summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-07 09:27:35 +0800
committerSukanka2022-06-07 09:27:35 +0800
commit64845fdab71c5cfb08f4461a468d8bbebebf14b1 (patch)
tree72993a7103e37c1a65c23df5573a6d7f712876f5
downloadaur-64845fdab71c5cfb08f4461a468d8bbebebf14b1.tar.gz
add r-tiledb
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD43
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ec8853319dd9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = r-tiledb
+ pkgdesc = Universal Storage Engine for Sparse and Dense Multidimensional Arrays
+ pkgver = 0.13.0
+ pkgrel = 3
+ url = https://cran.r-project.org/package=tiledb
+ arch = x86_64
+ license = MIT
+ depends = r
+ depends = r-nanotime
+ depends = r-rcpp
+ optdepends = r-bit64
+ optdepends = r-curl
+ optdepends = r-data.table
+ optdepends = r-knitr
+ optdepends = r-matrix
+ optdepends = r-minidown
+ optdepends = r-nycflights13
+ optdepends = r-palmerpenguins
+ optdepends = r-rmarkdown
+ optdepends = r-tibble
+ optdepends = r-tinytest
+ source = https://cran.r-project.org/src/contrib/tiledb_0.13.0.tar.gz
+ sha256sums = 6232aa633bc6cc90e51f9c4814e4d475f0755f55062844287d3919bcce40cdce
+
+pkgname = r-tiledb
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..013c9ab54a7f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# system requirements: A C++17 compiler is required, and on macOScompilation for version 11.14 is required. Optionally cmake(only when TileDB source build selected), git (only when TileDBsource build selected); on x86_64 and M1 platforms pre-builtTileDB Embedded libraries are available at GitHub and are usedif no TileDB installation is detected, and no other option tobuild or download was specified by the user.
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=tiledb
+_pkgver=0.13.0
+pkgname=r-${_pkgname,,}
+pkgver=0.13.0
+pkgrel=3
+pkgdesc='Universal Storage Engine for Sparse and Dense Multidimensional Arrays'
+arch=('x86_64')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('MIT')
+depends=(
+ r
+ r-nanotime
+ r-rcpp
+)
+optdepends=(
+ r-bit64
+ r-curl
+ r-data.table
+ r-knitr
+ r-matrix
+ r-minidown
+ r-nycflights13
+ r-palmerpenguins
+ r-rmarkdown
+ r-tibble
+ r-tinytest
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('6232aa633bc6cc90e51f9c4814e4d475f0755f55062844287d3919bcce40cdce')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -Dm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+# vim:set ts=2 sw=2 et: