summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2020-03-10 03:15:01 +0300
committerViktor Drobot2020-03-10 03:15:01 +0300
commitfa9d69b1ef24a8829d213f20293b4307bf7d0a86 (patch)
tree0d16556026c1bd7c0ba0193c6499a97f28b40d5c
parent51aa7e9b1fd9a43b3de7f96b187578f02f526a86 (diff)
downloadaur-fa9d69b1ef24a8829d213f20293b4307bf7d0a86.tar.gz
Fixed PKGBUILD
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD31
2 files changed, 20 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef2267111b50..b599efbdc18e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,8 +4,9 @@ pkgbase = r-timedate
pkgrel = 1
url = https://cran.r-project.org/package=timeDate
arch = any
- license = GPL
- depends = r
+ license = GPL2
+ license = GPL3
+ depends = r>=2.15.1
optdepends = r-date
optdepends = r-runit
source = https://cran.r-project.org/src/contrib/timeDate_3043.102.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 15c310496c56..f5798a5db2c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,30 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Ward Segers <w@rdsegers.be>
# Contributor: Alex Branham <branham@utexas.edu>
+
_cranname=timeDate
_cranver=3043.102
-_pkgtar=${_cranname}_${_cranver}.tar.gz
-pkgname=r-timedate
+pkgname=r-${_cranname,,}
pkgver=${_cranver//[:-]/.}
pkgrel=1
pkgdesc="Rmetrics - Chronological and Calendar Objects"
-arch=('any')
+arch=(any)
url="https://cran.r-project.org/package=${_cranname}"
-license=('GPL')
-depends=('r' )
-
-optdepends=('r-date' 'r-runit')
-
-source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
+license=(GPL2 GPL3)
+depends=('r>=2.15.1')
+optdepends=(r-date r-runit)
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
md5sums=('7808ada851cbf740b1360cabca0706ff')
-build(){
- R CMD INSTALL ${_pkgtar} -l $srcdir
+build() {
+ cd "${srcdir}"
+
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
}
+
package() {
- install -d "$pkgdir/usr/lib/R/library"
- cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
-}
+ cd "${srcdir}"
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+}