summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-07 01:42:05 +0800
committerSukanka2022-06-07 01:42:05 +0800
commit024477794a073550673e6c3ca86b13495e258310 (patch)
tree8a03d6b14187e5fd6e48bd2863bc9b933964498f
downloadaur-024477794a073550673e6c3ca86b13495e258310.tar.gz
add r-tin
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD39
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5361e3c680e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = r-tin
+ pkgdesc = Transcriptome instability analysis
+ pkgver = 1.28.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/TIN
+ arch = any
+ license = Artistic2.0
+ depends = r
+ depends = r-aroma.affymetrix
+ depends = r-data.table
+ depends = r-impute
+ depends = r-squash
+ depends = r-stringr
+ depends = r-wgcna
+ optdepends = r-affxparser
+ optdepends = r-aroma.light
+ optdepends = r-biocgenerics
+ optdepends = r-knitr
+ optdepends = r-runit
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/TIN_1.28.0.tar.gz
+ sha256sums = 96bc9b27e344939ae3e9d9661d880a1e3c486b38c934f869afcd15175b21facd
+
+pkgname = r-tin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94082c1fdb01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=TIN
+_pkgver=1.28.0
+pkgname=r-${_pkgname,,}
+pkgver=1.28.0
+pkgrel=1
+pkgdesc='Transcriptome instability analysis'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-aroma.affymetrix
+ r-data.table
+ r-impute
+ r-squash
+ r-stringr
+ r-wgcna
+)
+optdepends=(
+ r-affxparser
+ r-aroma.light
+ r-biocgenerics
+ r-knitr
+ r-runit
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('96bc9b27e344939ae3e9d9661d880a1e3c486b38c934f869afcd15175b21facd')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: