summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaha6622020-03-01 21:46:27 -0500
committerhaha6622020-03-01 21:46:27 -0500
commit2a80f92e11e38645e90f2ab4b3f8a9933892a0b6 (patch)
tree32b9b243be077079342000cf955603225de4179d
parent529fe1561e179e07fdaffd826d0dd6f08c23eb4b (diff)
downloadaur-2a80f92e11e38645e90f2ab4b3f8a9933892a0b6.tar.gz
Initialize and update to 0.20
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD39
2 files changed, 33 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 80f4c0851a4a..dd1637df2c31 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,19 @@
pkgbase = r-tinytex
- pkgdesc = Helper Functions to Install and Maintain TeX Live, and Compile LaTeX Documents
- pkgver = 0.8
+ pkgdesc = Helper Functions to Install and Maintain 'TeX Live', and Compile 'LaTeX' Documents
+ pkgver = 0.20
pkgrel = 1
url = https://cran.r-project.org/package=tinytex
arch = any
license = MIT
+ license = custom
depends = r
- depends = r-xfun>=0.3
- optdepends = r-testit
+ depends = r-xfun>=0.5
+ optdepends = r-textit
optdepends = r-rstudioapi
- source = https://cran.r-project.org/src/contrib/Archive//
- md5sums = d0dacfe98b6d0e06cbcb5b22216f0469
+ source = https://cran.r-project.org/src/contrib/tinytex_0.20.tar.gz
+ source = https://cran.r-project.org/web/packages/tinytex/LICENSE
+ sha256sums = 6f6e57d41d8057c17a864004ae6587a95ac3288672e16d35c829317d6d441b59
+ sha256sums = f58c2f5b0f10b231d9cea9bc4ea0d849cd4279a21d03257be8dc9fd9452fad37
pkgname = r-tinytex
diff --git a/PKGBUILD b/PKGBUILD
index 048c4425bc22..aa74f3b6fb0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,32 @@
+# Maintainer: haha662 <haha662 at outlook dot com>
# Contributor: Kibouo <csonka.mihaly@hotmail.com>
# Contributor: Alex Branham <branham@utexas.edu>
-_cranver=0.8
-pkgname=r-tinytex
+
+_cranname=tinytex
+_cranver=0.20
+pkgname=r-${_cranname,,}
pkgver=${_cranver//[:-]/.}
pkgrel=1
-pkgdesc='Helper Functions to Install and Maintain TeX Live, and Compile LaTeX Documents'
-arch=('any')
-url='https://cran.r-project.org/package=tinytex'
-license=('MIT')
-depends=('r' 'r-xfun>=0.3')
-optdepends=('r-testit' 'r-rstudioapi')
-source=("https://cran.r-project.org/src/contrib/Archive/${_cranname}/${_pkgtar}")
-md5sums=('d0dacfe98b6d0e06cbcb5b22216f0469')
+pkgdesc="Helper Functions to Install and Maintain 'TeX Live', and Compile 'LaTeX' Documents"
+arch=("any")
+url="https://cran.r-project.org/package=${_cranname}"
+license=("MIT" "custom")
+depends=("r" "r-xfun>=0.5")
+# makedepends=()
+optdepends=("r-textit" "r-rstudioapi")
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz" "https://cran.r-project.org/web/packages/tinytex/LICENSE")
+sha256sums=("6f6e57d41d8057c17a864004ae6587a95ac3288672e16d35c829317d6d441b59" "f58c2f5b0f10b231d9cea9bc4ea0d849cd4279a21d03257be8dc9fd9452fad37")
+
+build() {
+ cd "${srcdir}"
-build(){
- R CMD INSTALL tinytex_"$_cranver".tar.gz -l "$srcdir"
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
}
+
package() {
- install -dm0755 "$pkgdir"/usr/lib/R/library
- cp -a --no-preserve=ownership tinytex "$pkgdir"/usr/lib/R/library
-}
+ cd "${srcdir}"
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+}