summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-07 01:42:53 +0800
committerSukanka2022-06-07 01:42:53 +0800
commit47ff3ce2b02b15e023ed779ab8adfc9febd2e6c6 (patch)
treea33413fa6a36996dcd0a21627d216e0f4b500c90
downloadaur-47ff3ce2b02b15e023ed779ab8adfc9febd2e6c6.tar.gz
add r-tissueenrich
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD38
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc248a70ff83
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = r-tissueenrich
+ pkgdesc = Tissue-specific gene enrichment analysis
+ pkgver = 1.16.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/TissueEnrich
+ arch = any
+ license = MIT
+ depends = r
+ depends = r-dplyr
+ depends = r-ensurer
+ depends = r-ggplot2
+ depends = r-gseabase
+ depends = r-summarizedexperiment
+ depends = r-tidyr
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/TissueEnrich_1.16.0.tar.gz
+ sha256sums = 8170351320a92ea0fe06df72127af52d426994af367dd05f1697a9da88fa18d1
+
+pkgname = r-tissueenrich
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0151fa631bbd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=TissueEnrich
+_pkgver=1.16.0
+pkgname=r-${_pkgname,,}
+pkgver=1.16.0
+pkgrel=1
+pkgdesc='Tissue-specific gene enrichment analysis'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('MIT')
+depends=(
+ r
+ r-dplyr
+ r-ensurer
+ r-ggplot2
+ r-gseabase
+ r-summarizedexperiment
+ r-tidyr
+)
+optdepends=(
+ r-knitr
+ r-rmarkdown
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('8170351320a92ea0fe06df72127af52d426994af367dd05f1697a9da88fa18d1')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -Dm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+# vim:set ts=2 sw=2 et: