summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-04-15 18:19:19 +0000
committerBioArchLinuxBot2024-04-15 18:19:19 +0000
commit5eea06f979f9fef2c963b0f807a4204af32a9f97 (patch)
tree01bdedc89150654970d3133c01e9ce5975876a8d
parent20af4844d4bfe167248999d3e26bca6a3200f50d (diff)
downloadaur-5eea06f979f9fef2c963b0f807a4204af32a9f97.tar.gz
[lilac] updated to 1.22.0-2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD26
2 files changed, 17 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc0f006f6216..4d959cdc5749 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = r-tissueenrich
pkgdesc = Tissue-specific gene enrichment analysis
pkgver = 1.22.0
- pkgrel = 1
+ pkgrel = 2
url = https://bioconductor.org/packages/TissueEnrich
arch = any
license = MIT
- depends = r
depends = r-dplyr
depends = r-ensurer
depends = r-ggplot2
@@ -16,6 +15,7 @@ pkgbase = r-tissueenrich
optdepends = r-rmarkdown
optdepends = r-testthat
source = https://bioconductor.org/packages/release/bioc/src/contrib/TissueEnrich_1.22.0.tar.gz
- sha256sums = d258d871cd7463b80af875d214dfa7a76abc9bb13c7f13604ffe04bf0dbc8c8f
+ md5sums = 5cc00925f523a6d82b216343e7f4b81a
+ b2sums = d41c2a445c1ef71051e79dc00b1acfd4876a2153c92604a1362d9eec20aed59330e0947ec7e44827cac3a064961e889bb22d5134165d994e685aca5a3976ab27
pkgname = r-tissueenrich
diff --git a/PKGBUILD b/PKGBUILD
index 238e79bc0cbf..c126676071b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,13 @@
_pkgname=TissueEnrich
_pkgver=1.22.0
pkgname=r-${_pkgname,,}
-pkgver=1.22.0
-pkgrel=1
-pkgdesc='Tissue-specific gene enrichment analysis'
-arch=('any')
-url="https://bioconductor.org/packages/${_pkgname}"
+pkgver=${_pkgver//-/.}
+pkgrel=2
+pkgdesc="Tissue-specific gene enrichment analysis"
+arch=(any)
+url="https://bioconductor.org/packages/$_pkgname"
license=('MIT')
depends=(
- r
r-dplyr
r-ensurer
r-ggplot2
@@ -24,15 +23,18 @@ optdepends=(
r-testthat
)
source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('d258d871cd7463b80af875d214dfa7a76abc9bb13c7f13604ffe04bf0dbc8c8f')
+md5sums=('5cc00925f523a6d82b216343e7f4b81a')
+b2sums=('d41c2a445c1ef71051e79dc00b1acfd4876a2153c92604a1362d9eec20aed59330e0947ec7e44827cac3a064961e889bb22d5134165d994e685aca5a3976ab27')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
- install -Dm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ ln -s "/usr/lib/R/library/$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
}
-# vim:set ts=2 sw=2 et: