summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Branham2018-05-31 16:12:25 -0500
committerAlex Branham2018-05-31 16:12:25 -0500
commit0c4cba071144e84b723d3c1d1a4f07549e69b0ac (patch)
tree080a411af7599957260e3b2f5c54baf11e6ac4f0
parentc490b42ebc537aa54c475654528399e5505ee668 (diff)
downloadaur-0c4cba071144e84b723d3c1d1a4f07549e69b0ac.tar.gz
Package rename
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD35
2 files changed, 30 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ec93152babe..7cf84ee51ba9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
-pkgbase = r-cran-tnet
- pkgdesc = R package for analyzing weighted, two-mode, and longitudinal networks
+pkgbase = r-tnet
+ pkgdesc = Software for Analysis of Weighted, Two-Mode, and Longitudinal Networks
pkgver = 3.0.14
pkgrel = 1
- url = http://cran.r-project.org/web/packages/tnet/index.html
+ url = https://cran.r-project.org/package=tnet
arch = any
- license = CCPL:by-nc
+ license = GPL3
depends = r
- source = http://cran.r-project.org/src/contrib/tnet_3.0.14.tar.gz
+ depends = r-igraph
+ replaces = r-cran-tnet
+ source = https://cran.r-project.org/src/contrib/tnet_3.0.14.tar.gz
md5sums = 129a06065f7a0252f2fac3e5e6211f6e
-pkgname = r-cran-tnet
+pkgname = r-tnet
diff --git a/PKGBUILD b/PKGBUILD
index a506e8db2730..64a24bb33fec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,27 @@
-# Maintainer: fordprefect <fordprefect@dukun.de>
+# Maintainer: Alex Branham <branham@utexas.edu>
_cranname=tnet
-pkgname=r-cran-$_cranname
-pkgver=3.0.14
+_cranver=3.0.14
+_pkgtar=${_cranname}_${_cranver}.tar.gz
+pkgname=r-tnet
+pkgver=${_cranver//[:-]/.}
pkgrel=1
-pkgdesc="R package for analyzing weighted, two-mode, and longitudinal networks"
-url="http://cran.r-project.org/web/packages/${_cranname}/index.html"
+pkgdesc="Software for Analysis of Weighted, Two-Mode, and Longitudinal Networks"
arch=('any')
-license=('CCPL:by-nc')
-depends=('r')
-source=("http://cran.r-project.org/src/contrib/${_cranname}_${pkgver}.tar.gz")
+url="https://cran.r-project.org/package=${_cranname}"
+license=('GPL3')
+depends=('r' 'r-igraph')
+
+
+
+source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
md5sums=('129a06065f7a0252f2fac3e5e6211f6e')
-
-build() {
- mkdir -p ${pkgdir}/usr/lib/R/library
- cd ${srcdir}
- R CMD INSTALL ${_cranname} -l ${pkgdir}/usr/lib/R/library
+replaces=('r-cran-tnet')
+
+build(){
+ R CMD INSTALL ${_pkgtar} -l $srcdir
}
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
+}
+