summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-07 01:47:33 +0800
committerSukanka2022-06-07 01:47:33 +0800
commitb8cd698033a4c5402414744df63f819268fa9e8b (patch)
treec868aef1ab4060464ee4c6ba7d43e6fc280d3805
downloadaur-b8cd698033a4c5402414744df63f819268fa9e8b.tar.gz
add r-tofsims
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD42
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bfc7b751f09c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = r-tofsims
+ pkgdesc = Import, process and analysis of Time-of-Flight Secondary Ion Mass Spectrometry (ToF-SIMS) imaging data
+ pkgver = 1.22.0
+ pkgrel = 3
+ url = https://bioconductor.org/packages/tofsims
+ arch = x86_64
+ license = GPL
+ depends = r
+ depends = r-als
+ depends = r-alsace
+ depends = r-protgenerics
+ depends = r-rcpp
+ depends = r-rcpparmadillo
+ depends = r-signal
+ optdepends = r-biocparallel
+ optdepends = r-ebimage
+ optdepends = r-knitr
+ optdepends = r-parallel
+ optdepends = r-rcolorbrewer
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ optdepends = r-tofsimsdata
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/tofsims_1.22.0.tar.gz
+ sha256sums = c5fc9186e49526545d00ed4d461715f5e280da267f7c747d1028b3c507414435
+
+pkgname = r-tofsims
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d5619484cb94
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=tofsims
+_pkgver=1.22.0
+pkgname=r-${_pkgname,,}
+pkgver=1.22.0
+pkgrel=3
+pkgdesc='Import, process and analysis of Time-of-Flight Secondary Ion Mass Spectrometry (ToF-SIMS) imaging data'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-als
+ r-alsace
+ r-protgenerics
+ r-rcpp
+ r-rcpparmadillo
+ r-signal
+)
+optdepends=(
+ r-biocparallel
+ r-ebimage
+ r-knitr
+ r-parallel
+ r-rcolorbrewer
+ r-rmarkdown
+ r-testthat
+ r-tofsimsdata
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('c5fc9186e49526545d00ed4d461715f5e280da267f7c747d1028b3c507414435')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: