summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-07 01:51:12 +0800
committerSukanka2022-06-07 01:51:12 +0800
commitd743edc6e67356f9cb6a2ca66b2d8d91a3bdb9c8 (patch)
treed8340e58ae35b78cd67765c595a5e171ddd2e715
downloadaur-d743edc6e67356f9cb6a2ca66b2d8d91a3bdb9c8.tar.gz
add r-tpp
-rw-r--r--.SRCINFO41
-rw-r--r--PKGBUILD57
2 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fbe43b7572ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,41 @@
+pkgbase = r-tpp
+ pkgdesc = Analyze thermal proteome profiling (TPP) experiments
+ pkgver = 3.24.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/TPP
+ arch = any
+ license = Artistic2.0
+ depends = r
+ depends = r-biobase
+ depends = r-biobroom
+ depends = r-broom
+ depends = r-data.table
+ depends = r-doparallel
+ depends = r-dplyr
+ depends = r-foreach
+ depends = r-futile.logger
+ depends = r-ggplot2
+ depends = r-gridextra
+ depends = r-knitr
+ depends = r-limma
+ depends = r-magrittr
+ depends = r-mefa
+ depends = r-nls2
+ depends = r-openxlsx
+ depends = r-plyr
+ depends = r-purrr
+ depends = r-rcolorbrewer
+ depends = r-rcurl
+ depends = r-reshape2
+ depends = r-rmarkdown
+ depends = r-stringr
+ depends = r-tibble
+ depends = r-tidyr
+ depends = r-venndiagram
+ depends = r-vgam
+ optdepends = r-biocstyle
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/TPP_3.24.0.tar.gz
+ sha256sums = 9454d11a0a89a95888d3a0b375ddf8337ad5348653df809a042a57c136e40f70
+
+pkgname = r-tpp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65dd5ba98e79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=TPP
+_pkgver=3.24.0
+pkgname=r-${_pkgname,,}
+pkgver=3.24.0
+pkgrel=1
+pkgdesc='Analyze thermal proteome profiling (TPP) experiments'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-biobase
+ r-biobroom
+ r-broom
+ r-data.table
+ r-doparallel
+ r-dplyr
+ r-foreach
+ r-futile.logger
+ r-ggplot2
+ r-gridextra
+ r-knitr
+ r-limma
+ r-magrittr
+ r-mefa
+ r-nls2
+ r-openxlsx
+ r-plyr
+ r-purrr
+ r-rcolorbrewer
+ r-rcurl
+ r-reshape2
+ r-rmarkdown
+ r-stringr
+ r-tibble
+ r-tidyr
+ r-venndiagram
+ r-vgam
+)
+optdepends=(
+ r-biocstyle
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('9454d11a0a89a95888d3a0b375ddf8337ad5348653df809a042a57c136e40f70')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: