summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-07 02:07:06 +0800
committerSukanka2022-06-07 02:07:06 +0800
commitc5a949187bef602a3ac2b1aff377a325c3bd49a3 (patch)
tree3503d7585839233079dabd288a4e8a0021ef714f
downloadaur-c5a949187bef602a3ac2b1aff377a325c3bd49a3.tar.gz
add r-truncnorm
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD29
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4a93148b9108
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = r-truncnorm
+ pkgdesc = Truncated Normal Distribution
+ pkgver = 1.0.8
+ pkgrel = 4
+ url = https://cran.r-project.org/package=truncnorm
+ arch = x86_64
+ license = GPL
+ depends = r
+ optdepends = r-testthat
+ source = https://cran.r-project.org/src/contrib/truncnorm_1.0-8.tar.gz
+ sha256sums = 49564e8d87063cf9610201fbc833859ed01935cc0581b9e21c42a0d21a47c87e
+
+pkgname = r-truncnorm
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c62dbf9fa7fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=truncnorm
+_pkgver=1.0-8
+pkgname=r-${_pkgname,,}
+pkgver=1.0.8
+pkgrel=4
+pkgdesc='Truncated Normal Distribution'
+arch=('x86_64')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+)
+optdepends=(
+ r-testthat
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('49564e8d87063cf9610201fbc833859ed01935cc0581b9e21c42a0d21a47c87e')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: