summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2023-11-28 22:32:10 +0200
committerPekka Ristola2023-11-28 22:32:10 +0200
commitd2e854a5ec73ed4ce718552c705d3136acf56ec4 (patch)
treeccc9006c60a65b12e858b034bdf8846e14269cd1
downloadaur-d2e854a5ec73ed4ce718552c705d3136acf56ec4.tar.gz
Version 1.0.0
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD54
2 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..74011ba17547
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = r-tsar
+ pkgdesc = Thermal Shift Analysis in R
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/TSAR
+ arch = any
+ license = AGPL3
+ checkdepends = r-testthat
+ depends = r-dplyr
+ depends = r-ggplot2
+ depends = r-ggpubr
+ depends = r-jsonlite
+ depends = r-magrittr
+ depends = r-minpack.lm
+ depends = r-openxlsx
+ depends = r-plotly
+ depends = r-readxl
+ depends = r-rhandsontable
+ depends = r-shiny
+ depends = r-shinyjs
+ depends = r-shinywidgets
+ depends = r-stringr
+ depends = r-tidyr
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/TSAR_1.0.0.tar.gz
+ md5sums = 7cc8589151c5b03e247590bbd7dc04dd
+ sha256sums = bc75e3ad29377425c1da1b43cef760445d71ea47d8fc0a0390705d3778b9f0cd
+
+pkgname = r-tsar
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80d9a7b3e25e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_pkgname=TSAR
+_pkgver=1.0.0
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="Thermal Shift Analysis in R"
+arch=(any)
+url="https://bioconductor.org/packages/${_pkgname}"
+license=(AGPL3)
+depends=(
+ r-dplyr
+ r-ggplot2
+ r-ggpubr
+ r-jsonlite
+ r-magrittr
+ r-minpack.lm
+ r-openxlsx
+ r-plotly
+ r-readxl
+ r-rhandsontable
+ r-shiny
+ r-shinyjs
+ r-shinywidgets
+ r-stringr
+ r-tidyr
+)
+checkdepends=(
+ r-testthat
+)
+optdepends=(
+ r-knitr
+ r-rmarkdown
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('7cc8589151c5b03e247590bbd7dc04dd')
+sha256sums=('bc75e3ad29377425c1da1b43cef760445d71ea47d8fc0a0390705d3778b9f0cd')
+
+build() {
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+check() {
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" NOT_CRAN=true Rscript --vanilla testthat.R
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+}