summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-07 02:13:11 +0800
committerSukanka2022-06-07 02:13:11 +0800
commiteb602b32a7e1fe95d834a2ff061a664c66645738 (patch)
tree5ccf66c2a7dac8672239c3e5290473a117eefa86
downloadaur-eb602b32a7e1fe95d834a2ff061a664c66645738.tar.gz
add r-tvtb
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD56
2 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..65794742fb21
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+pkgbase = r-tvtb
+ pkgdesc = TVTB: The VCF Tool Box
+ pkgver = 1.22.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/TVTB
+ arch = any
+ license = Artistic2.0
+ depends = r
+ depends = r-annotationfilter
+ depends = r-biocgenerics
+ depends = r-biocparallel
+ depends = r-biostrings
+ depends = r-ensembldb
+ depends = r-ensemblvep
+ depends = r-genomeinfodb
+ depends = r-genomicranges
+ depends = r-ggally
+ depends = r-ggplot2
+ depends = r-gviz
+ depends = r-iranges
+ depends = r-limma
+ depends = r-reshape2
+ depends = r-rsamtools
+ depends = r-s4vectors
+ depends = r-summarizedexperiment
+ depends = r-variantannotation
+ optdepends = r-biocstyle
+ optdepends = r-covr
+ optdepends = r-dt
+ optdepends = r-ensdb.hsapiens.v75
+ optdepends = r-knitr
+ optdepends = r-pander
+ optdepends = r-rmarkdown
+ optdepends = r-rtracklayer
+ optdepends = r-shiny
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/TVTB_1.22.0.tar.gz
+ sha256sums = 1af5da609ec7b34cc10f5fe898bebf786f4fac573044fee992c86fe15df4dd00
+
+pkgname = r-tvtb
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64d04abcddfd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=TVTB
+_pkgver=1.22.0
+pkgname=r-${_pkgname,,}
+pkgver=1.22.0
+pkgrel=1
+pkgdesc='TVTB: The VCF Tool Box'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-annotationfilter
+ r-biocgenerics
+ r-biocparallel
+ r-biostrings
+ r-ensembldb
+ r-ensemblvep
+ r-genomeinfodb
+ r-genomicranges
+ r-ggally
+ r-ggplot2
+ r-gviz
+ r-iranges
+ r-limma
+ r-reshape2
+ r-rsamtools
+ r-s4vectors
+ r-summarizedexperiment
+ r-variantannotation
+)
+optdepends=(
+ r-biocstyle
+ r-covr
+ r-dt
+ r-ensdb.hsapiens.v75
+ r-knitr
+ r-pander
+ r-rmarkdown
+ r-rtracklayer
+ r-shiny
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('1af5da609ec7b34cc10f5fe898bebf786f4fac573044fee992c86fe15df4dd00')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: