summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-07 02:17:35 +0800
committerSukanka2022-06-07 02:17:35 +0800
commit0bf4039ad48af13a1a41ffa0096610b42b2f8462 (patch)
treee9582f02789761eb1b4249aa52a6f2b1dd3c1c79
downloadaur-0bf4039ad48af13a1a41ffa0096610b42b2f8462.tar.gz
add r-txdb.hsapiens.ucsc.hg38.knowngene
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1bc80fe94b67
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = r-txdb.hsapiens.ucsc.hg38.knowngene
+ pkgdesc = Annotation package for TxDb object(s)
+ pkgver = 3.15.0
+ pkgrel = 3
+ url = https://bioconductor.org/packages/TxDb.Hsapiens.UCSC.hg38.knownGene
+ arch = any
+ license = Artistic2.0
+ depends = r
+ depends = r-annotationdbi
+ depends = r-genomicfeatures
+ source = https://bioconductor.org/packages/release/data/annotation/src/contrib/TxDb.Hsapiens.UCSC.hg38.knownGene_3.15.0.tar.gz
+ sha256sums = e92069ef6ccf6ec5ab6395d195c9f83b11ef944012b0be06f1f6f13227c42ef9
+
+pkgname = r-txdb.hsapiens.ucsc.hg38.knowngene
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..72abcef5ca44
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=TxDb.Hsapiens.UCSC.hg38.knownGene
+_pkgver=3.15.0
+pkgname=r-${_pkgname,,}
+pkgver=3.15.0
+pkgrel=3
+pkgdesc='Annotation package for TxDb object(s)'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-annotationdbi
+ r-genomicfeatures
+)
+source=("https://bioconductor.org/packages/release/data/annotation/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('e92069ef6ccf6ec5ab6395d195c9f83b11ef944012b0be06f1f6f13227c42ef9')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: