summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-07 02:18:23 +0800
committerSukanka2022-06-07 02:18:23 +0800
commitd56dcea965f0cb874b926f7b5d16afc17c0ca15e (patch)
tree83e0643cab79218c22b7ae9c8393f9595ab7d523
downloadaur-r-txdb.mmusculus.ucsc.mm9.knowngene.tar.gz
add r-txdb.mmusculus.ucsc.mm9.knowngene
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5060886dca2a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = r-txdb.mmusculus.ucsc.mm9.knowngene
+ pkgdesc = Annotation package for TxDb object(s)
+ pkgver = 3.2.2
+ pkgrel = 4
+ url = https://bioconductor.org/packages/TxDb.Mmusculus.UCSC.mm9.knownGene
+ arch = any
+ license = Artistic2.0
+ depends = r
+ depends = r-annotationdbi
+ depends = r-genomicfeatures
+ source = https://bioconductor.org/packages/release/data/annotation/src/contrib/TxDb.Mmusculus.UCSC.mm9.knownGene_3.2.2.tar.gz
+ sha256sums = a2d760206336d0c1ba48108ba3e23b201aa429a6b88a19437270980180ef7299
+
+pkgname = r-txdb.mmusculus.ucsc.mm9.knowngene
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32cfecc4a8a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=TxDb.Mmusculus.UCSC.mm9.knownGene
+_pkgver=3.2.2
+pkgname=r-${_pkgname,,}
+pkgver=3.2.2
+pkgrel=4
+pkgdesc='Annotation package for TxDb object(s)'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-annotationdbi
+ r-genomicfeatures
+)
+source=("https://bioconductor.org/packages/release/data/annotation/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('a2d760206336d0c1ba48108ba3e23b201aa429a6b88a19437270980180ef7299')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: