summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-07 02:33:42 +0800
committerSukanka2022-06-07 02:33:42 +0800
commit90daa172a93e7ad336adc5247b93fa377750e9ef (patch)
tree623d356d85ca8f2231ad2ca0dd52fa96949cfbea
downloadaur-90daa172a93e7ad336adc5247b93fa377750e9ef.tar.gz
add r-vbmp
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e1705645917f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = r-vbmp
+ pkgdesc = Variational Bayesian Multinomial Probit Regression
+ pkgver = 1.64.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/vbmp
+ arch = any
+ license = GPL
+ depends = r
+ optdepends = r-biobase
+ optdepends = r-statmod
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/vbmp_1.64.0.tar.gz
+ sha256sums = 16647f0c60bae0870e5d87d5a0205e982464c216b03f30eac610d626aadabd0b
+
+pkgname = r-vbmp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c95fda1a9f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=vbmp
+_pkgver=1.64.0
+pkgname=r-${_pkgname,,}
+pkgver=1.64.0
+pkgrel=1
+pkgdesc='Variational Bayesian Multinomial Probit Regression'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+)
+optdepends=(
+ r-biobase
+ r-statmod
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('16647f0c60bae0870e5d87d5a0205e982464c216b03f30eac610d626aadabd0b')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: