summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-07 02:41:22 +0800
committerSukanka2022-06-07 02:41:22 +0800
commit84c9fc8e86d2067f3bc013744727ce0e39d6d31b (patch)
tree051e3feef77972d81888bc0e7912c68ad019bc99
downloadaur-84c9fc8e86d2067f3bc013744727ce0e39d6d31b.tar.gz
add r-viper
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8d3f9d1191c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = r-viper
+ pkgdesc = Virtual Inference of Protein-activity by Enriched Regulon analysis
+ pkgver = 1.30.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/viper
+ arch = any
+ license = custom
+ depends = r
+ depends = r-biobase
+ depends = r-e1071
+ depends = r-mixtools
+ optdepends = r-bcellviper
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/viper_1.30.0.tar.gz
+ sha256sums = 1d602263433bdf03350e0f86b5b1bf5cbc7e022303ce4d6176dcbebfc0732646
+
+pkgname = r-viper
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f23ffa412447
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=viper
+_pkgver=1.30.0
+pkgname=r-${_pkgname,,}
+pkgver=1.30.0
+pkgrel=1
+pkgdesc='Virtual Inference of Protein-activity by Enriched Regulon analysis'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('custom')
+depends=(
+ r
+ r-biobase
+ r-e1071
+ r-mixtools
+)
+optdepends=(
+ r-bcellviper
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('1d602263433bdf03350e0f86b5b1bf5cbc7e022303ce4d6176dcbebfc0732646')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -Dm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+# vim:set ts=2 sw=2 et: