summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Fink2023-03-26 19:03:40 +0300
committerChristoph Fink2023-03-26 19:03:40 +0300
commit8197be92f50ef480f8344f8a1801856e1151aee0 (patch)
treefa4ad6a9997f2cd24a1509a7e65c55ccf2b639a0
parent76402cb94666398616f158a259df17ba2f58c448 (diff)
downloadaur-8197be92f50ef480f8344f8a1801856e1151aee0.tar.gz
upgpkg: r-viridislite 0.4.1-3
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD33
2 files changed, 25 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e090f8009824..fb24c3fc3e47 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,10 @@
pkgbase = r-viridislite
pkgdesc = Colorblind-Friendly Color Maps (Lite Version)
pkgver = 0.4.1
- pkgrel = 2
+ pkgrel = 3
url = https://cran.r-project.org/package=viridisLite
arch = any
license = MIT
- checkdepends = r-covr
- checkdepends = r-hexbin>=1.27.0
- checkdepends = r-ggplot2>=1.0.1
- checkdepends = r-testthat
depends = r>=2.10
optdepends = r-covr
optdepends = r-hexbin>=1.27.0
diff --git a/PKGBUILD b/PKGBUILD
index cdea26d80df8..56bb212104ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgdesc="Colorblind-Friendly Color Maps (Lite Version)"
url="https://cran.r-project.org/package=${_cranname}"
license=("MIT")
pkgver=${_cranver//[:-]/.}
-pkgrel=2
+pkgrel=3
arch=("any")
depends=(
@@ -20,10 +20,25 @@ optdepends=(
"r-hexbin>=1.27.0"
"r-ggplot2>=1.0.1"
)
-checkdepends=(
- "${optdepends[@]}"
- "r-testthat"
-)
+
+# The unittests for `r-viridislite` have multiple circular
+# dependency chains.
+
+# As such, the tests can not be run on first build.
+# While R packages from CRAN, generally, are well-tested
+# before they are released, in some situations, you want to
+# have thorough testing on your own end.
+
+# To run the tests, first build this package without `check()`
+# (i.e., as-is) to bootstrap `r-viridislite`. Then, on subsequent builds,
+# (assumining you have a local repository that is accessible from
+# the build chroot), uncomment the lines defining `checkdepends`, below,
+# as well as the `check()` function further down
+
+# checkdepends=(
+# "${optdepends[@]}"
+# "r-testthat"
+# )
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
b2sums=("024b7470a96a8f487ddf58b02f3efd96ccd7d54ee2de6a1ff88b070570543d8f08e6a95dc5530d197d45014b6f5403c8375a572f96f84693bb010725a04893cd")
@@ -33,14 +48,14 @@ build() {
R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}/build/"
}
-check() {
- R_LIBS="build/" R CMD check --no-manual --as-cran "${_cranname}"
-}
+# check() {
+# export R_LIBS="build/"
+# R CMD check --no-manual "${_cranname}"
+# }
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
cp -a --no-preserve=ownership "${srcdir}/build/${_cranname}" "${pkgdir}/usr/lib/R/library"
-
if [[ -f "${_cranname}/LICENSE" ]]; then
install -Dm0644 "${_cranname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
fi