summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-07 02:44:59 +0800
committerSukanka2022-06-07 02:44:59 +0800
commit43266345c0828e262f238b4b3b3b2d14a04b69a3 (patch)
treee5ef49be9d5082420397d714cf0455c6324c76ce
downloadaur-43266345c0828e262f238b4b3b3b2d14a04b69a3.tar.gz
add r-vulcan
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD43
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..70f87e299476
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = r-vulcan
+ pkgdesc = VirtUaL ChIP-Seq data Analysis using Networks
+ pkgver = 1.18.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/vulcan
+ arch = any
+ license = LGPL
+ depends = r
+ depends = r-biobase
+ depends = r-catools
+ depends = r-chippeakanno
+ depends = r-csaw
+ depends = r-deseq2
+ depends = r-diffbind
+ depends = r-genomicranges
+ depends = r-gplots
+ depends = r-locfit
+ depends = r-s4vectors
+ depends = r-txdb.hsapiens.ucsc.hg19.knowngene
+ depends = r-viper
+ depends = r-wordcloud
+ depends = r-zoo
+ optdepends = r-vulcandata
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/vulcan_1.18.0.tar.gz
+ sha256sums = 5c388c810df921125c0fad9ce5b196a3dea1baff739a338f026fd850afaf2f39
+
+pkgname = r-vulcan
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f85d2abf1504
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=vulcan
+_pkgver=1.18.0
+pkgname=r-${_pkgname,,}
+pkgver=1.18.0
+pkgrel=1
+pkgdesc='VirtUaL ChIP-Seq data Analysis using Networks'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('LGPL')
+depends=(
+ r
+ r-biobase
+ r-catools
+ r-chippeakanno
+ r-csaw
+ r-deseq2
+ r-diffbind
+ r-genomicranges
+ r-gplots
+ r-locfit
+ r-s4vectors
+ r-txdb.hsapiens.ucsc.hg19.knowngene
+ r-viper
+ r-wordcloud
+ r-zoo
+)
+optdepends=(
+ r-vulcandata
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('5c388c810df921125c0fad9ce5b196a3dea1baff739a338f026fd850afaf2f39')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: