summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-11-04 18:03:33 +0000
committerBioArchLinuxBot2023-11-04 18:03:33 +0000
commitbd22d2fb8549ff72b88c25422e834cd9b8db0223 (patch)
tree1ea5082ff39ab47bfc97b7663c1886b0512aeca2
parent37eb75edb5df32893dabd62e2fe7f47c6f4e8be9 (diff)
downloadaur-bd22d2fb8549ff72b88c25422e834cd9b8db0223.tar.gz
[lilac] updated to 1.16.0-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD33
2 files changed, 24 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3118e1d3cb88..4bfabe37ad5b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = r-waddr
pkgdesc = Statistical tests for detecting differential distributions based on the 2-Wasserstein distance
- pkgver = 1.14.0
+ pkgver = 1.16.0
pkgrel = 1
url = https://bioconductor.org/packages/waddR
arch = x86_64
license = MIT
- depends = r
+ makedepends = r-rcpparmadillo
depends = r-arm
depends = r-biocfilecache
depends = r-biocparallel
depends = r-eva
depends = r-rcpp
- depends = r-rcpparmadillo
depends = r-singlecellexperiment
optdepends = r-devtools
optdepends = r-knitr
@@ -20,7 +19,8 @@ pkgbase = r-waddr
optdepends = r-rprojroot
optdepends = r-scater
optdepends = r-testthat
- source = https://bioconductor.org/packages/release/bioc/src/contrib/waddR_1.14.0.tar.gz
- sha256sums = f4e289f0a83a40d9488791a78c781a4e2cb21c2fef1a5309511b0b74680d6bc8
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/waddR_1.16.0.tar.gz
+ md5sums = 97a692c918d531e3d872dc17141cd112
+ sha256sums = 675e24e4135651c3b0618452334769d5388f21a45979acd82fd1f6b84bbf451d
pkgname = r-waddr
diff --git a/PKGBUILD b/PKGBUILD
index 46afd049258f..b086d518e32e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,26 @@
-# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: Guoyi Zhang <guoyizhang at malacology dot net>
_pkgname=waddR
-_pkgver=1.14.0
+_pkgver=1.16.0
pkgname=r-${_pkgname,,}
-pkgver=1.14.0
+pkgver=${_pkgver//-/.}
pkgrel=1
-pkgdesc='Statistical tests for detecting differential distributions based on the 2-Wasserstein distance'
-arch=('x86_64')
+pkgdesc="Statistical tests for detecting differential distributions based on the 2-Wasserstein distance"
+arch=(x86_64)
url="https://bioconductor.org/packages/${_pkgname}"
-license=('MIT')
+license=(MIT)
depends=(
- r
r-arm
r-biocfilecache
r-biocparallel
r-eva
r-rcpp
- r-rcpparmadillo
r-singlecellexperiment
)
+makedepends=(
+ r-rcpparmadillo
+)
optdepends=(
r-devtools
r-knitr
@@ -29,15 +31,18 @@ optdepends=(
r-testthat
)
source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('f4e289f0a83a40d9488791a78c781a4e2cb21c2fef1a5309511b0b74680d6bc8')
+md5sums=('97a692c918d531e3d872dc17141cd112')
+sha256sums=('675e24e4135651c3b0618452334769d5388f21a45979acd82fd1f6b84bbf451d')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
- install -Dm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ ln -s "/usr/lib/R/library/$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
}
-# vim:set ts=2 sw=2 et: