summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-03-07 18:05:40 +0000
committerBioArchLinuxBot2024-03-07 18:05:40 +0000
commit425aed574ac21148c6756be83c42b055772d3422 (patch)
tree3a160b3dcd78abd54aed4be1867fab6f4105133c
parent8fad60bc9a4548a28b2a3e663afa32dcd63a63e8 (diff)
downloadaur-425aed574ac21148c6756be83c42b055772d3422.tar.gz
[lilac] updated to 1.24.1-2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD26
2 files changed, 20 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 81e833a2f6c6..b4a1b43dcb18 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = r-weibullness
pkgdesc = Goodness-of-Fit Test for Weibull Distribution (Weibullness)
pkgver = 1.24.1
- pkgrel = 1
+ pkgrel = 2
url = https://cran.r-project.org/package=weibullness
arch = any
- license = GPL
+ license = GPL-2.0-only OR GPL-3.0-only
depends = r
+ optdepends = r-bsgof
source = https://cran.r-project.org/src/contrib/weibullness_1.24.1.tar.gz
- sha256sums = a1dfa37132da69f030b6701031af14b7ca887fcba04caa90d6aad123b6425c1c
+ md5sums = 3725675d4d305d1ffe3f7ca8d2392132
+ b2sums = e720ac9abe50b74199c74ed717a1b0d5e7f2778eeef5e3b9b1a6b9b94e0781364e10687616d6aeea0d553e385c7384d1cba1d51a273ac40779cacd901e629bd4
pkgname = r-weibullness
diff --git a/PKGBUILD b/PKGBUILD
index 8eed8b17cd64..8b5f2b2a8a8a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,28 @@
_pkgname=weibullness
_pkgver=1.24.1
pkgname=r-${_pkgname,,}
-pkgver=1.24.1
-pkgrel=1
-pkgdesc='Goodness-of-Fit Test for Weibull Distribution (Weibullness)'
-arch=('any')
-url="https://cran.r-project.org/package=${_pkgname}"
-license=('GPL')
+pkgver=${_pkgver//-/.}
+pkgrel=2
+pkgdesc="Goodness-of-Fit Test for Weibull Distribution (Weibullness)"
+arch=(any)
+url="https://cran.r-project.org/package=$_pkgname"
+license=('GPL-2.0-only OR GPL-3.0-only')
depends=(
r
)
+optdepends=(
+ r-bsgof
+)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('a1dfa37132da69f030b6701031af14b7ca887fcba04caa90d6aad123b6425c1c')
+md5sums=('3725675d4d305d1ffe3f7ca8d2392132')
+b2sums=('e720ac9abe50b74199c74ed717a1b0d5e7f2778eeef5e3b9b1a6b9b94e0781364e10687616d6aeea0d553e385c7384d1cba1d51a273ac40779cacd901e629bd4')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: